Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

GO 2.4 now downloads to older Apple devices

Discussion in 'Pro/Adv Discussion' started by Oso, Oct 27, 2015.

  1. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,534
    Likes Received:
    1,480
    Location:
    Sacramento CA
    Hi guys. Based on another thread, as a test I just now tried to download the latest GO app (2.4) from the App Store to my old 3rd generation iPad. To my surprise, it downloaded and actually launched.

    An iPad 3 and iPad 4 were previously too old to even begin the download. Anyone trying would get the "device not compatible" error.

    The App store now says the GO app requires iOS 8 or later and then only an iPhone, iPad, or iPod Touch. No list of devices.
    20151027 GO app info App Store.JPG

    The DJI site still lists the specific devices, all of which are newer than the iPad 4.
    20151027 GO app info DJI.JPG

    I haven't tried it to fly with my iPad 3 and I for sure will never try it, but the fact that it downloaded and launched the GO app is very interesting. I have to think that this will be changed soon so that the previous "device not compatible" error message is back for the old devices.

    I'm sure that someone will try to use the older devices to fly while they have the chance. At least the ones with a lightning connector. I can't imagine that the old devices would work well considering their under powered processors.

    Please fly safe out there!
     
    #1 Oso, Oct 27, 2015
    Last edited: Nov 24, 2015
    JoBe likes this.
  2. Mark Kim

    Joined:
    Aug 3, 2015
    Messages:
    6
    Likes Received:
    2
    1 it doesn't fit on controller
    2 it is noticeably slow

    Sticking with iPhone 6+
     
  3. gfredrone

    Joined:
    Jan 24, 2014
    Messages:
    1,221
    Likes Received:
    191
    :eek::eek::eek:
    Video feed won't go over the old 30 pin connector. Pull your panties up and chill out. :eek::p:confused:;)o_O:tongueclosed:
     
  4. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,142
    Likes Received:
    1,658
    Location:
    San Francisco, CA
    I downloaded to iPad mini 2 and is working great
     
  5. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,534
    Likes Received:
    1,480
    Location:
    Sacramento CA
    That's good to hear. Mini 2 was always compatible, so at least we know it still works along with the older devices that never used to work (download) before 2.4 came out.
     
    JoBe likes this.
  6. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,534
    Likes Received:
    1,480
    Location:
    Sacramento CA
    Wow, how did panties get in this old thread?

    I would also assume the much older 30 pin devices would be able to download and launch the app, but not pass the video feed via the old connector. I'm not certain without trying.

    However, there are devices that were previously too old to download the app (got the "device not compatible" message) such as the iPhone 5, iPad 4, iPad Mini 1 to name a few that DO have the lightning connector and ARE now able to download the app. I would assume that they would be able to connect to the RC and pass the video feed.

    Still chilled out as always, thanks sir. Cheers!
     
    #6 Oso, Nov 17, 2015
    Last edited: Nov 17, 2015
    JoBe likes this.
  7. GadgetGuy

    Joined:
    Jun 18, 2015
    Messages:
    4,459
    Likes Received:
    1,294
    ...and it's way too heavy! :eek:
    My wrists thanked me when I upgraded from it!