Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

iPad mini 4 - not connecting- NOW SOLVED :-)

Discussion in 'Pro/Adv Discussion' started by robinb, Apr 6, 2016.

  1. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    I have been using my iphone 6+ upto now.



    Just aquired a ipad mini 4. Latest ios 9.3.1
    First of all did a restore of software from my phone to ipad using go app 2.4.3
    The ipad pings when it connects.
    However it said disconnected and no camera view.
    Re-installed app - same.
    Changed cable - same
    Turned everything off and on - same.
    Ok bit the bullet and upgraded the app to 2.7.1 from iTunes.
    now ipad still pings when i plug it in. but I do NOT get any connection option on main screen.
    re started everything - nothing.
    Plugged in iphone, works fine.
    Any ideas ?
     
    #1 robinb, Apr 6, 2016
    Last edited: Apr 6, 2016
  2. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,044
    Likes Received:
    1,624
    Location:
    San Francisco, CA
    Im not sure if Go app extracted from your iPhone will work on iPad. Delete the app and install fresh 2.7.1 again.

    Follow the sequence: RC on >>> Go App on >>> Aircraft on
     
    #2 alokbhargava, Apr 6, 2016
    Last edited: Apr 6, 2016
  3. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Yes but if you read further down i reinstalled a clean version from iTunes.
     
  4. alokbhargava

    Joined:
    Sep 28, 2015
    Messages:
    5,044
    Likes Received:
    1,624
    Location:
    San Francisco, CA
    I thought you didn't delete the previous one and updated to 2.7.1. My mistake.

    For a clean installation, delete the app first, reboot and then download and install. This may not make any difference but worth trying.
     
  5. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Tried both ways and rebooting in between.

    Still does not work with iPad mini, works with iPhone.
     
  6. sonof40

    Joined:
    Oct 22, 2015
    Messages:
    514
    Likes Received:
    82
    Location:
    San Ramon, CA
    Did you reboot (power down) the mini?
     
  7. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Yes, multiple times.
    Also all the other stuff.
     
  8. happydays

    Joined:
    Jul 5, 2013
    Messages:
    1,845
    Likes Received:
    655
    Location:
    Warrenpoint, Ireland
    I would connect it to itunes and wipe it down, then load on the apps that you want one at a time.
     
  9. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    I am trying that now.

    Just reset back to factory and erased the whole device and just loading go app.
     
  10. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    The only app on there now is the go app and the factory preinstalled ones, it still will not connect.
     
  11. CCDD

    Joined:
    Nov 20, 2015
    Messages:
    650
    Likes Received:
    384
    Location:
    US
    I just had the same issue with my new iPad Pro. You're going to end up losing your 2.4.3 version. You'll need to place the Mini in recovery mode. Turn off your iPad and hold down the home button as you plug it in to iTunes on your Mac or PC. You can let go once you see the iTunes connection appear on your screen. From there you can completely wipe the iPad and restore to factory settings. Upon completion, you'll need to set up the iPad as new and not restore it from a prior backup. I had to go through this for days before it was figured out. I was also on 2.4.3 however, I think this is the only was to fix you issue. PM me with more questions.
     
  12. tshrira

    Joined:
    Feb 9, 2016
    Messages:
    15
    Likes Received:
    2
    I also got an iPad Air after using iPhone 6 + , Same problem ,did you manage to solve that issue mate?


    Sent from my iPad using PhantomPilots mobile app
     
  13. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun

    I wiped iPad and set it up as new device from the iPad itself.
    installed 2.7.1 go app and that as only app on device.

    still would not connect.
     
  14. CCDD

    Joined:
    Nov 20, 2015
    Messages:
    650
    Likes Received:
    384
    Location:
    US
    When clearing the iPad without the use of iTunes you're not resetting to factory settings. Try what I'm telling you, it likely will fix your problem.
     
    skyeboysteve likes this.
  15. tshrira

    Joined:
    Feb 9, 2016
    Messages:
    15
    Likes Received:
    2
    Hi I just did a clean restore from iTunes , it fixed that issue for me , thx CCDD


    Sent from my iPad using PhantomPilots mobile app
     
    Kweaton likes this.
  16. CCDD

    Joined:
    Nov 20, 2015
    Messages:
    650
    Likes Received:
    384
    Location:
    US
    Glad to hear it worked. I think this problem is going to be a continuing problem for those still on DJI Go version 2.4.3 or older. If one purchases a new IOS device and attempts to set it up using a backup from prior device with iOS 9.3.1 or later, it appears there's some issue preventing the FPV from connecting. I also have a Mini 2 which I upgraded to 9.3.1 and that seems to work with the aforementioned version of DJI app. It's only when restoring from backup that problems happen. FWIW, Litchi also didn't work until I erased new iPad and set up as new.
     
  17. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Thanks, I am doing a recovery mode restore on iPad mini at present.
    Let you know how it works out in an hour or so.
     
  18. marzipana

    Joined:
    Jan 9, 2016
    Messages:
    290
    Likes Received:
    33
    Same boat...went from an iPhone 6+ and just flew for the first time with an iPad Mini 4 - I'd installed a back up from my phone onto it so it was running Go 2.4.3. I couldn't connect at first, until I turned everything off and uplugged the Mini...then turned on remote, AC, plugged in Mini and then I was able to connect and I did actually fly. But I'm also going to restore to factory settings and set it up with the latest Go app, I don't fancy taking a long drive somewhere to fly only to discover I can't connect to the AC.
     
  19. peterepeat69

    Joined:
    Mar 18, 2016
    Messages:
    549
    Likes Received:
    110
    Just acquired my new p3a running on an iPad mini 3 that is on a version before 9.3.1, go app asks me to update, iPad asks me to update but I won't as my bird works fine, seems like upgrading anything bricks everything. If it ain't broke don't fix it.


    Sent from my iPad using PhantomPilots mobile app
     
  20. robinb

    Joined:
    May 10, 2014
    Messages:
    2,907
    Likes Received:
    503
    Location:
    A place in the sun
    Ok, just done a complete factory install (iTunes recovery mode).

    App 2.7.1 will now connect to my iPad mini