Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Into the River Repair Advice

Discussion in 'Phantom 2 Vision + Discussion' started by 3Rivers, Jul 16, 2014.

  1. 3Rivers

    Joined:
    Jun 7, 2014
    Messages:
    4
    Likes Received:
    0
    Crashed my Vision Plus into the river, totally user error. I am a dumbass.

    Fished it out, dried it out per all of the conventional wisdom. Recovered the SD card (awesome video by the way)

    The good news:

    Camera, gimbal, FPV, GPS are all functioning normally. Captures clear photo and video. Good FPV signal to phone, shows good telemetry.

    The bad news:

    No signal from remote to Phantom. Motors don't fire up. Getting "Configuration Error" message.

    I imagine main controller on the board is toast. Before I drop 229 on controller, can anyone help me diagnose if this is the real problem.

    Thanks
     
  2. Jeffin916

    Joined:
    Jun 20, 2014
    Messages:
    251
    Likes Received:
    86
    Location:
    Roseville, CA
    I did the same exact thing. Granted mine did not fully submerged under the water and it was only for about 4 seconds. Here is what I did. I took an air compressor and I blew out any excess water out of the drone. I then opened up the top and I sumerge the whole drone in rice for 24 hours. By then took a blow dryer just tried to evaporate any type of water that might exist. After that, I had two re connect thephantom phone app with the wifi because it wasn't talking to it anymore. After I did not, it all work again. I wish you the best of luck and hope that you get your bird back to life
     
  3. Mal_PV2_Ireland

    Joined:
    Mar 4, 2014
    Messages:
    2,589
    Likes Received:
    1,230
    Location:
    Dublin Ireland
    Some people would advise t immediately remove the battery after recovery, wash down with lots of distilled water, dry as much as possible with an air compressor then get it into rice for a few days. After that you then need to start diagnosing what parts of your bird have failed which is the hard part and then replace as necessary. Sorry I cant offer any more detailed advice on the fixing part.
     
  4. DronePilot

    Joined:
    May 9, 2014
    Messages:
    113
    Likes Received:
    0
    Look for deionized water rather than distilled water to flush. Ions in water are what destroys electronics such chlorine or salt.
     
  5. Mal_PV2_Ireland

    Joined:
    Mar 4, 2014
    Messages:
    2,589
    Likes Received:
    1,230
    Location:
    Dublin Ireland
    +1 silly me, I meant deionized water. Been a long day :roll:
     
  6. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,413
    Likes Received:
    567
    Location:
    Sydney Australia
    New Toothbrush and methylated spirits. Then leave to dry. The Toothbrush removes much more.
     
  7. EMCSQUAR

    Joined:
    Sep 5, 2013
    Messages:
    1,692
    Likes Received:
    6
    Location:
    N 44.895 W 93.354 Minnesota
    Try rebinding Tx to your Phantom, then put on assistant -> tools -> restore default settings -> do ALL calibrations Advanced IMU, stick, battery and compass cal.
     
  8. 3Rivers

    Joined:
    Jun 7, 2014
    Messages:
    4
    Likes Received:
    0
    Thanks for all the advice. Tried all these steps, no luck so far getting her airborne...

    When I turn on the Tx, the red binding light on the Phantom turns off, which tells me it is getting a signal. I may just start replacing the guts and see what happens.
     
  9. WyattEarp

    Joined:
    Jun 21, 2014
    Messages:
    109
    Likes Received:
    0
    Hey how about a link to the video. You did say it was awesome.
     
  10. yali

    Joined:
    Nov 8, 2013
    Messages:
    148
    Likes Received:
    0
    Can you share the video ?
     
  11. rrmccabe

    Joined:
    Jul 2, 2014
    Messages:
    1,647
    Likes Received:
    358
    Location:
    Ankeny, Iowa
    Have you tried this with camera unhooked? My 2+ has camera issues and the motors will not spool up with the camera attached. It's a factory problem and they are replacing it but something was inhibiting start. Camera removed and it flies fine.