Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Intermittent Problem With Gimbal

Discussion in 'Zenmuse H3-3D/H4-3D GoPro Gimbal' started by Martycox51, Mar 15, 2015.

  1. Martycox51

    Joined:
    May 13, 2014
    Messages:
    6
    Likes Received:
    0
    I have the Zenmuse H3-3D GoPro Gimbal on my Phantom 2. Recently it has developed an intermittent problem of jerking to one side or the other for about 1-2 seconds, then resetting back to the normal position. It usually does this when I'm beginning a slow turn. It has not been through a crash or hard landing. Does anyone out there have an idea of what's going on and what I can do to fix the problem?
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,410
    Likes Received:
    567
    Location:
    Sydney Australia
    your h33d is going limp because there is a bias in the weight distribution. What gopro is it? I know that the H33d was built specifically for the GoPro 3 non plus. The 3 BE plus and the 4 blacks need to be counterbalanced.
    There are 2 things you need to do.
    First is an ADV IMU. Do it on a surface that is levelled with the horizon. Use a spirit level if you have to. This will fix small tilts that may cause enough bias to make it go limp.
    Second is to check if your gimbal is neutral balanced. When the phantom is off, does the gimbal flop to oneside? If so, then you need add counter weights until the gimbal "floats". This will minimise stress on the motors.
     
  3. Martycox51

    Joined:
    May 13, 2014
    Messages:
    6
    Likes Received:
    0
    Thank you very much! I will try what you have suggested. By the way, I'm using the gopro 4 black edition.
     
  4. wkf94025

    Joined:
    Jan 19, 2014
    Messages:
    608
    Likes Received:
    8
    Location:
    St. Helena, CA
    I would also make sure you are on a fairly recent version of Zenmuse firmware. Gimbal snap was more common several releases ago, in my experience.
     
  5. legrandphoto

    Joined:
    Jan 1, 2014
    Messages:
    35
    Likes Received:
    1
    Location:
    Florida
    mine does something similar. I have been flying the GoPro 3+ Black since last September and everyone in a while it would do the "Gimbal Snap". Got fed up with it this weekend as it happened in the middle of a few long straight flights rendering them unusable. I recently added the Polar Pro filters but it was snapping before I stared flying with them. Yesterday it was pretty windy which I thought had something to do with it. I have a video posted on Vimeo showing the "Gimbal Snap" . all my software and firmware is up to date.
     
  6. Joesrevolution

    Joined:
    May 14, 2014
    Messages:
    203
    Likes Received:
    18
    Location:
    Devon
    Mine does exactly the same as this too, I have the most up to date firmware with a 3+ black. Did an imu when I installed the gimbal and am still having the problem, balance is fine with the gimbal staying in whatever position i put it in. Will be watching this thread, hopefully its nothing too tricky to fix...