Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

help with rapid red flashing lights

Discussion in 'Phantom 2 Help' started by mustang_52, Mar 24, 2014.

  1. mustang_52

    Joined:
    Feb 23, 2014
    Messages:
    80
    Likes Received:
    0
    So ive taken my phantom 2 out for a few flights and worked like a charm. Decided to finally add the fpv setup to the mix and now ive got problems. I wired up an immersionrc 5.8 600 transmitter and iosd mini. Now i took it outside, did a calibration dance and got two sets of rapid flashing green indicating homelock and sat lock. then i get a slow green flash. fire up the motorsand take off and get a steady rapid red flashing and it auto lands each time. I had two bars on the battery when doing this. what could be wrong?
     
  2. aadvanboven

    Joined:
    Nov 28, 2013
    Messages:
    24
    Likes Received:
    0
    Maybe with the extra payload your battery voltage drops quicker then before. What settings are you using for voltage protection within the Naza assistant ?
     
  3. mustang_52

    Joined:
    Feb 23, 2014
    Messages:
    80
    Likes Received:
    0
    Stock at 30% and 15%. according to the phantom assitant im at 32% now. Im lost because I the fpv setup works but it just keeps going to a flashing red and returns to home.
     
  4. aadvanboven

    Joined:
    Nov 28, 2013
    Messages:
    24
    Likes Received:
    0
    What if you keep the components on the p2 but doesn't turn the fpv transmitter on. Maybe the signal blocks the signal of the controller so it will go into failsafe. You have to el
     
  5. aadvanboven

    Joined:
    Nov 28, 2013
    Messages:
    24
    Likes Received:
    0
    .... You have to eliminate the changes from before one by one....
     
  6. mustang_52

    Joined:
    Feb 23, 2014
    Messages:
    80
    Likes Received:
    0
    They way i was doing it was the components are on under the p2 but im not using the monitor. I didnt have it yet so I couldnt test it with it on but it does seem like a signal issue but how would that be since the controller is 2.4 andthe fpv is 5.8?
     
  7. mustang_52

    Joined:
    Feb 23, 2014
    Messages:
    80
    Likes Received:
    0
    Turns out that it just needed a full charge. Seemed at about 18 minutes I got a green flash them red flash for about 19 seconds then went to rapid red flashing and landed itself. I'm assuming this is normal behavior with fpv equipment onboard to drain that fast?

    Sent from my HTC One using Tapatalk