Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

HELP !! motors won't start - everything seems fine?!?

Discussion in 'Phantom 2 Vision + Discussion' started by Jimgermani, Sep 26, 2014.

  1. Jimgermani

    Joined:
    May 2, 2014
    Messages:
    12
    Likes Received:
    0
    HELP!! I did my first flight with the unofficial ground station app. an hour ago (have done around 100 flights otherwise so far) - everything worked great, no problems at all.

    I just went outside to do my second flight of the day and although everything SEEMS to be working perfectly, when I put the joysticks in the position to start the motors, nothing happens. I can see the gimball moving, so I know the controller is connnected and sending information, but nothing happens with the props. I've rebooted everything several times, changed batteries, nothing seems to work.

    Anyone have any ideas??
     
  2. Jimgermani

    Joined:
    May 2, 2014
    Messages:
    12
    Likes Received:
    0
    update..... tried a few hours later and did a few test flights and everything works fine. no idea why?? by the way, i forgot to add to my last post - i didn't think it had anything to do with the app. (i hadn't even activated the GS app yet, i was just trying to take off manually so i could fly to 200 feet and start the waypoint flight.)

    has anyone had this experience where the motors just didn't start no matter what you did? mabye wifi interference? there are 6-7 wifi connections in the area that I was flying.
     
  3. RobC

    Joined:
    Sep 7, 2014
    Messages:
    2
    Likes Received:
    0
    I had a similar problem after I'd powered down, then powered up. http://www.phantompilots.com/viewtopic.php?f=27&t=25818 Today for my second flight, after changing batteries, I tried starting the motors as soon as I powered up the Phantom, before it took time to acquire satellites. (I then of course waited for satellite acquisition before taking off.) That worked; the motors started just as they should. Maybe that's just dumb luck, but for now I'm content.
     
  4. Jimgermani

    Joined:
    May 2, 2014
    Messages:
    12
    Likes Received:
    0
    another update... tried again this morning - no luck. everything seems perfect but props won't start
     
  5. 4wd

    4wd

    Joined:
    Mar 31, 2014
    Messages:
    2,532
    Likes Received:
    427
    Location:
    North York Moors
    Have you ever calibrated the sticks?
    It's possible that moving to the extreme points to start isn't being read as such by the software.
     
  6. DrJoe

    Joined:
    Apr 13, 2014
    Messages:
    592
    Likes Received:
    97
    With updated firmware, is it possible you are in a "no fly zone"?
    Is your compass calibrated?
    Is it a bad battery?
    What is the light sequence of the LED's?
     
Loading...
Similar Threads - HELP motors won't Forum Date
Standard Help Motors won't start Phantom 3 Help Apr 27, 2016
help please. motors won't start Phantom 2 Vision + Discussion Aug 3, 2014
Help with Motors for phantom advance 3 Pro/Adv Discussion Oct 29, 2016
Motors Surging in Flight! Help!? Pro/Adv Discussion Sep 27, 2016
Help! Sand in the motors Pro/Adv Discussion Sep 5, 2016