Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional help FW update fails every time.

Discussion in 'Phantom 3 Help' started by droneshop, Nov 7, 2015.

  1. droneshop

    Joined:
    Mar 23, 2015
    Messages:
    125
    Likes Received:
    29
    Location:
    Calgary, AB
    see link here, posted full hidden log, fails on version checking 6 every time,
    I am not a noob, have updated countless aircraft
    I have tried everything normally suggested, new cables, new camera, new lightbridge module, new sd cards, new downloads, reformatted, etc etc.
    looking for what piece of hardware might be stalling the update.

    DJI Forum|help,upgrade keeps failing

    thanks,
     
  2. droneshop

    Joined:
    Mar 23, 2015
    Messages:
    125
    Likes Received:
    29
    Location:
    Calgary, AB
    latest log:
    [00012516]========== remo-con disconnect. boot(15) ============
    [00012567]Packet [C:\P3X_FW_V01.03.0020.bin] detected, card sn [0x290997ff].
    [00012608]Packet upgrade start...

    [00012654]Packet checking...
    [00012701]Packet vlink 01.03.0020 <-> 01.01.0009.
    [00012778]Done.

    [00012825]Version checking[1]...
    [00012907][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00012982][03 06][00] v2.3.0.13 -> v2.2.6.19
    [00013044][04 00][00] v1.41.0.0 -> v1.40.0.0
    [00013110][09 00][00] v1.7.0.3 -> v1.7.0.3
    [00013327][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00013415][12 00][00] v1.10.0.0 -> v1.8.0.0
    [00013515][12 01][00] v1.10.0.0 -> v1.8.0.0
    [00013615][12 02][00] v1.10.0.0 -> v1.8.0.0
    [00013715][12 03][00] v1.10.0.0 -> v1.8.0.0
    [00022363][15 00][00] device not detected.
    [00022452][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00022575][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00022651][19 00][00] v1.0.8.59 -> v1.0.8.96 need upgrade.
    [00022696][01 00][00] v1.23.3419 -> v1.23.3419
    [00022746][01 01][00] v1.23.3419 -> v1.23.3419
    [00022810][08 00][00] v0.12.0.4 -> v0.12.0.4
    [00022853]Done.

    [00024898]Waiting for user confirm...
    [00034947]Timeout, start upgrade automatically.

    [00035036]Firmware upgrading[1]...
    [00037298][19 00] Firmware upgrade start...
    [00150155][19 00] Firmware upgrade finish failed (step = 3, err = 0xaa).
    [00180205]Done.

    [00180267]Version checking[2]...
    [00180336][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00180416][03 06][00] v2.3.0.13 -> v2.2.6.19
    [00180478][04 00][00] v1.41.0.0 -> v1.40.0.0
    [00180540][09 00][00] v1.7.0.3 -> v1.7.0.3
    [00180675][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00180796][12 00][00] v1.10.0.0 -> v1.8.0.0
    [00180905][12 01][00] v1.10.0.0 -> v1.8.0.0
    [00181004][12 02][00] v1.10.0.0 -> v1.8.0.0
    [00181104][12 03][00] v1.10.0.0 -> v1.8.0.0
    [00184135][15 00][00] device not detected.
    [00184236][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00184362][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00184420][19 00][00] v1.0.8.59 -> v1.0.8.96 need upgrade.
    [00184467][01 00][00] v1.23.3419 -> v1.23.3419
    [00184513][01 01][00] v1.23.3419 -> v1.23.3419
    [00184569][08 00][00] v0.12.0.4 -> v0.12.0.4
    [00184612]Done.

    [00184658]Firmware upgrading[2]...
    [00186934][19 00] Firmware upgrade start...
    [00298981][19 00] Firmware upgrade finish failed (step = 3, err = 0xaa).
    [00329030]Done.

    [00329082]Version checking[3]...
    [00329164][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00329244][03 06][00] v2.3.0.13 -> v2.2.6.19
    [00329294][04 00][00] v1.41.0.0 -> v1.40.0.0
    [00329367][09 00][00] v1.7.0.3 -> v1.7.0.3
    [00329584][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00329692][12 00][00] v1.10.0.0 -> v1.8.0.0
    [00329797][12 01][00] v1.10.0.0 -> v1.8.0.0
    [00329892][12 02][00] v1.10.0.0 -> v1.8.0.0
    [00329998][12 03][00] v1.10.0.0 -> v1.8.0.0
    [00333031][15 00][00] device not detected.
    [00333127][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00333248][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00333308][19 00][00] v1.0.8.59 -> v1.0.8.96 need upgrade.
    [00333356][01 00][00] v1.23.3419 -> v1.23.3419
    [00333406][01 01][00] v1.23.3419 -> v1.23.3419
    [00333478][08 00][00] v0.12.0.4 -> v0.12.0.4
    [00333523]Done.

    [00333573]Firmware upgrading[3]...
    [00335835][19 00] Firmware upgrade start...
    [00447892][19 00] Firmware upgrade finish failed (step = 3, err = 0xaa).
    [00477938]Done.

    [00477983]Version checking[4]...
    [00478072][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00478152][03 06][00] v2.3.0.13 -> v2.2.6.19
    [00478208][04 00][00] v1.41.0.0 -> v1.40.0.0
    [00478317][09 00][00] v1.7.0.3 -> v1.7.0.3
    [00478452][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00478541][12 00][00] v1.10.0.0 -> v1.8.0.0
    [00478616][12 01][00] v1.10.0.0 -> v1.8.0.0
    [00478733][12 02][00] v1.10.0.0 -> v1.8.0.0
    [00478833][12 03][00] v1.10.0.0 -> v1.8.0.0
    [00481864][15 00][00] device not detected.
    [00481961][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00482081][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00482156][19 00][00] v1.0.8.59 -> v1.0.8.96 need upgrade.
    [00482209][01 00][00] v1.23.3419 -> v1.23.3419
    [00482267][01 01][00] v1.23.3419 -> v1.23.3419
    [00482322][08 00][00] v0.12.0.4 -> v0.12.0.4
    [00482373]Done.

    [00482419]Firmware upgrading[4]...
    [00484683][19 00] Firmware upgrade start...
    [00596738][19 00] Firmware upgrade finish failed (step = 3, err = 0xaa).
    [00626785]Done.

    [00626831]Version checking[5]...
    [00626920][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00627000][03 06][00] v2.3.0.13 -> v2.2.6.19
    [00627072][04 00][00] v1.41.0.0 -> v1.40.0.0
    [00627144][09 00][00] v1.7.0.3 -> v1.7.0.3
    [00627260][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00627433][12 00][00] v1.10.0.0 -> v1.8.0.0
    [00627534][12 01][00] v1.10.0.0 -> v1.8.0.0
    [00627634][12 02][00] v1.10.0.0 -> v1.8.0.0
    [00627734][12 03][00] v1.10.0.0 -> v1.8.0.0
    [00630771][15 00][00] device not detected.
    [00630865][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00630990][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00631065][19 00][00] v1.0.8.59 -> v1.0.8.96 need upgrade.
    [00631113][01 00][00] v1.23.3419 -> v1.23.3419
    [00631160][01 01][00] v1.23.3419 -> v1.23.3419
    [00631222][08 00][00] v0.12.0.4 -> v0.12.0.4
    [00631270]Done.

    [00631316]Firmware upgrading[5]...
    [00633584][19 00] Firmware upgrade start...
    [00745647][19 00] Firmware upgrade finish failed (step = 3, err = 0xaa).
    [00775696]Done.

    [00775743]Version checking[6]...
    [00775828][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00775908][03 06][00] v2.3.0.13 -> v2.2.6.19
    [00775965][04 00][00] v1.41.0.0 -> v1.40.0.0
    [00776033][09 00][00] v1.7.0.3 -> v1.7.0.3
    [00776148][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00776242][12 00][00] v1.10.0.0 -> v1.8.0.0
    [00776343][12 01][00] v1.10.0.0 -> v1.8.0.0
    [00776442][12 02][00] v1.10.0.0 -> v1.8.0.0
    [00776542][12 03][00] v1.10.0.0 -> v1.8.0.0
    [00779570][15 00][00] device not detected.
    [00779662][17 00][00] v1.1.1.7 -> v1.1.1.7
    [00779797][17 01][00] v1.0.2.7 -> v1.0.2.7
    [00779873][19 00][00] v1.0.8.59 -> v1.0.8.96 need upgrade.
    [00779920][01 00][00] v1.23.3419 -> v1.23.3419
    [00779967][01 01][00] v1.23.3419 -> v1.23.3419
    [00780033][08 00][00] v0.12.0.4 -> v0.12.0.4
    [00780076]Packet upgrade failed at firmware upgrade.
     
  3. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,409
    Likes Received:
    567
    Location:
    Sydney Australia
    That's weirding me out..
    "00184135][15 00][00] device not detected."
    Could be your vision system? Gimbal?
    Asked some else for a successful upgrade log and see if the what 10th line should be.
    Have you detached something like your positioning system? gps? gimbal? could even be the controller on the main board.
     
  4. dmiles

    Joined:
    Apr 5, 2015
    Messages:
    62
    Likes Received:
    7
    I would love to know what piece of equipment each of those are. I have one that kept failing, number 8 and 15. Replacing the gimbal solved the issue.
     
  5. EODcrab

    Joined:
    Nov 8, 2015
    Messages:
    3
    Likes Received:
    1
    I am having a 'No Signal' issue. Everything works except live video feed. I have tried everything. The only other issue I have identified is the inability to update the Firmware. I am having the same issues as you are. LED on the gimbal turns red and I get the solid D---- sound. I am in Afghanistan so I was hoping to be able to fix it myself without a warranty return. If I remove the .bin file from the SD card everything shows like it was updated on the APP.

    I can still take pictures and video, just cannot see the live feed.
     

    Attached Files:

  6. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Try reformatting the SD card. Sometimes that is the issue.
     
  7. EODcrab

    Joined:
    Nov 8, 2015
    Messages:
    3
    Likes Received:
    1
    I have reformatted; with MAC, the RC, Windows. All firmware has been tried to no avail,
     
  8. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    One of the chaps here tonight did a cold IMU calibration and said that it fixed this problem. Might try that and see if that works for you.
    Check this thread.
    No Video Feed and Non Responsive Gimbal - Fixed
     
  9. Poundofnuts

    Joined:
    Jul 6, 2015
    Messages:
    208
    Likes Received:
    34
    Wow, this problem just keeps happening. They should change the DJI Phantom 3 name to DJI "no signal".
     
  10. Aryo

    Joined:
    Oct 16, 2015
    Messages:
    17
    Likes Received:
    0
    Hi, I have the same problem, after upgrading to 1.5 - No Signal and no video feed. and same 08 and 15 item not detected. Any updates on those? will try to cold calibrate tonight. How far are metal objects should be when you're doing IMU calibration? My house made of steel frames and cladding.
    Thanks.
     
  11. JamesBandes

    Joined:
    Jul 23, 2015
    Messages:
    112
    Likes Received:
    10
    Just a quick update in case this happens to anyone else. If you upgrading your firmware and it failes and the gimble light on the front is solid red and it makes a steady tone you are in trouble. If you look in the hidden miscelanous folder you will see a log file. When you open it you will see two errors about devices [15 00] and device [08 00] not detected. I repair facility told me that you have to open the bird and disconnect the ribbon cable (which is glued) and then reconnect and run the update again. I did not want to do this and am returning it for a repalcement.

    It is an error that causes you to lose your vido signal.

    I have checked my logs after an update failure to see this:
    [00029255][15 00][00] device not detected.
    [00042483][08 00][00] device not detected.
     
  12. Aryo

    Joined:
    Oct 16, 2015
    Messages:
    17
    Likes Received:
    0
    Thanks, somehow after some wiggling to the cables all modules are now ok. and update finished successfully, after more than 10 fails.
    A new problem arise, the gps icon on top screen is greyed out and no GPS satellite connected. I've flip the left front switch back and forth, still not working.

    Any suggestions?
    Thanks
     
  13. JamesBandes

    Joined:
    Jul 23, 2015
    Messages:
    112
    Likes Received:
    10
    So many problems with this firmware. I received a steady tone and a red light on the gimble. Finally gave up and sent it back to DJI for repair. They say 3 weeks. Lets see how long it really will take. Christmas and New Years what a great time to have to send it back for repair. It will be interesting to see what firmware will be on it when its returned.
     
  14. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Everything else working on the Device with the app?
     
  15. AndrewH

    Joined:
    Dec 5, 2015
    Messages:
    8
    Likes Received:
    1
    i'm in the same boat, everything works perfectly cept live feed, same device errors, i did remove my gimbal and leave it unplugged , power cycled it and reinstalled , it didnt help. next is cold recalibaration. the cable inside must be hooked up to more than just the gimbal/camera. i could send it away and wait or ........ open the top up :)
     
  16. AndrewH

    Joined:
    Dec 5, 2015
    Messages:
    8
    Likes Received:
    1
    [00691859]Version checking[3]...
    [00691916][03 05][00] v34.2.0.9 -> v34.2.0.9
    [00691976][03 06][05] v2.4.0.5 -> v2.4.0.5
    [00692023][04 00][05] v1.41.0.0 -> v1.41.0.0
    [00692136][11 00][00] v1.7.0.0 -> v1.7.0.0
    [00692230][12 00][00] v1.10.0.0 -> v1.10.0.0
    [00692410][12 01][00] v1.10.0.0 -> v1.10.0.0
    [00692490][12 02][00] v1.10.0.0 -> v1.10.0.0
    [00692565][12 03][00] v1.10.0.0 -> v1.10.0.0
    [00705098][15 00][00] device not detected.
    [00705164][17 00][05] v1.1.1.7 -> v1.1.1.7
    [00705280][17 01][05] v1.0.2.7 -> v1.0.2.7
    [00705340][19 00][00] v1.0.8.96 -> v1.0.8.96
    [00705376][01 00][05] v1.26.4315 -> v1.26.4315
    [00705408][01 01][05] v1.26.4315 -> v1.26.4315
    [00717940][08 00][00] device not detected.
    [00717983][09 00][05] v2.13.0.0 -> v2.13.0.0
    [00718021]Packet upgrade failed at version checking.
     
  17. AndrewH

    Joined:
    Dec 5, 2015
    Messages:
    8
    Likes Received:
    1
    just did the cold recalibration, no change. tried software upgrade again and stops after 10 sec or so, same errors on device 8,15. oh well its a lemon dji even though brand new out of box today.
     
  18. Aryo

    Joined:
    Oct 16, 2015
    Messages:
    17
    Likes Received:
    0
    info from another thread, it's most likely ribbon cable or any cable, thus my wiggling somehow fixed it.
    a little confession, I put it in the fridge, planning to do 'cold' calibration in an attempt to cure it. supposed to be 5 minutes, forgot and left the bird in there for almost 20minutes. When I took it out, condensation started to build up and it's all wet, so I cancel the calibration and dry it out using a fan overnight.
    Next day, I reinstall DJI GO app, attempted the update again, and voila.... it was a success...

    and yes, aside from the GPS, everything else seems to be working fine in the app, haven't tried to fly it though.
     
  19. JamesBandes

    Joined:
    Jul 23, 2015
    Messages:
    112
    Likes Received:
    10
    Send it back. Current period for repair is 3 Weeks
     
  20. Aryo

    Joined:
    Oct 16, 2015
    Messages:
    17
    Likes Received:
    0
    A quick update regarding my GPS problem and the previous no signal and no camera feed problems after update to 1.5, everything is now a-ok.
    GPS greyed out: After reinstalling the DJI GO app, I went to the usual field, and a little patience about 5~7minutes, the GPS is back, though a little bit slow to catch stronger signal and satellites at first power up. however, it's back to normal after second and third flight.
    no signal and camera feed: cable wiggling

    additional experience: Cold IMU calibration to speed up warming up really works. But not by inserting the bird in the fridge. I just make it as cold as possible at night under direct full blown ac for about half hour or when you think it's already a tad colder than the room temperature, and started the IMU calibration immediately after powering up. I did by preparing the app at the IMU Calibration menu prior to warming up, and tap right after the startup noise. Before this, my warming up can take up to almost a minute, now, just a few seconds, i think it's under 10 seconds and ready to fly.

    Thanks all for the help. great-great forum to look for assistance.