Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Great upgrade to 3.0, but lasted 1 day

Discussion in 'Phantom 2 Discussion' started by Malta_Air_Vision, Apr 9, 2014.

  1. Malta_Air_Vision

    Joined:
    Mar 21, 2014
    Messages:
    4
    Likes Received:
    0
    Location:
    Malta
    When I bought my Phantom, it was with firmware 1.8, and all worked well, including tilt on the gimbal H2-3D. Then I upgraded to 2.0 and all worked well as well, apart from the tilt on my gimbal. Now, I upgraded to 3.0, to see if my tilt on the gimbal, was fixed, and behold, I could not believe my eyes when I seen it moving slowly, at the same speed I was moving the lever on the remote control.

    One day later, I plugged it in to serif all ok, and once again, without me touching any tabs, or buttons, or whatever, my tilt went again, and I can only go up and down and that it.

    Is anyone else, having this problem please. Now its becoming frustrated. Only had the tilt on the camera working for one day. I have a go-pro hero 3+ connected.

    I would appreciate some help, if someone knows, or has gone through similar circumstances.

    Thank you.
     
  2. Malta_Air_Vision

    Joined:
    Mar 21, 2014
    Messages:
    4
    Likes Received:
    0
    Location:
    Malta
    Wow, Fixed.

    This person is a genius. Follow exactly what this image says, and it will work. Finally it worked for me. Thanks Lenrage.
     

    Attached Files: