Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal stopped responding to pitch control lever D6

Discussion in 'General Discussion' started by stewdaddy, Feb 8, 2014.

  1. stewdaddy

    Joined:
    Feb 6, 2014
    Messages:
    41
    Likes Received:
    0
    Update.....I figured it out, just had to calibrate the X1 in Phantom Assistant


    Hi,
    I am completely new to radio control. I recently purchased the phantom 2 & Gimbal h3-2d. I have carefully gone through and set up everything. After I set up the Gimbal, I noticed that the pitch control lever on the back of the D6 transmitter rotated the pitch of my gopro / gimbal 90 degrees. I plugged in the phantom 2 and upgraded the gimbal firmware IMU to version 1.8 and CMU to version 1.0. The pitch control was still working on the Gimbal after I did this. I turned everything off and went to the store.

    When I came back and turned it on, the Gimbal is now not responding to the pitch control lever. All the lights on the Phantom 2 are green. I have attached a picture of the gimbal position on startup. Any help, tips, or anything would be greatly appreciated. I'm very new at this, taking it slow and easy.
     

    Attached Files:

  2. VeritasDolet

    Joined:
    Jan 29, 2014
    Messages:
    34
    Likes Received:
    0
  3. stewdaddy

    Joined:
    Feb 6, 2014
    Messages:
    41
    Likes Received:
    0
    Thanks, I finally figured it out. Just had to calibrate the X1 in Phantom Assistant software. One question - after calibrating it's like I barely move the lever and the camera swings from -1000 to 1000. It will not stop in between at any other angle. I have tried re-calibrating but can't seem to slow it down any?