Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. media100

    Joined:
    Apr 17, 2016
    Messages:
    3
    Likes Received:
    0
    Hello, just got my 2nd factory new P4 (as a replacement for the first one) with exactly the same issues:

    1.) the gimbal makes a short squeaking sound on bootup of the copter

    2.) when the gimbal roll is adjusted manually by the DJI Go app, I make a SINGLE tap on the + and - buttons of the gimbal roll adjustment in the app, but the gimbal "jumps" in TWO delayed steps even if I only click ONCE on one of the + and - buttons.....weird, because I just can't get gimbal roll adjusted with a few fast clicks, I adjust it and then it "jumps"/moves again !

    Do you also experience these two issues with your P4 and what's the solution ?

    DJI service Europe told me that the dual gimbal adjustment "jumps" are a hardware issue and the copter should be replaced. Now I have the second factory new P4 and it's all the same like with the first one (gimbal squeaks and gimbal roll adjustment "dual jump" issues). Maybe all is just a firmware issue and not hardware related ? Should I get get the copter replaced a third time or wait for new firmware ?

    Thanks for your help....
     
  2. Sim597

    Joined:
    Mar 5, 2016
    Messages:
    1,040
    Likes Received:
    266
    Did you read the post about some of the screws are just loose. Seems they have a bad run of torque settings on the gimbal finishing install/finishing line.

    Dji ph4 Gimbal Screaming issue !!!


    Sent from my iPhone using PhantomPilots mobile app
     
  3. Sim597

    Joined:
    Mar 5, 2016
    Messages:
    1,040
    Likes Received:
    266
    Sorry, this is about the noise, but could theoretically be the case I guess.


    Sent from my iPhone using PhantomPilots mobile app
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    When my camera points at a steep upward angle, it sometimes rubs against the ribbon cable -- which makes a squeaking sound. Perhaps yours is doing the same thing.
     
  5. media100

    Joined:
    Apr 17, 2016
    Messages:
    3
    Likes Received:
    0
    No...the gimbal doesn't touch the ribbon cable but I'll try to fasten the screws...hope that helps.

    What about the problem with the gimbal roll adjustment (roll jumps TWICE by ONE roll adjustment click). Could someone please check this issue with the P4 ? I would like to know, if this is a general P4 problem or an issue with my P4 only.

    Thanks for your help !
     
  6. 4proppilot

    4proppilot Guest

    Mine does the same. For a little squeak I am not bothering to swap it. It seems to operate as normal


    Sent from my iPad using PhantomPilots mobile app
     
  7. Stevie_UK

    Joined:
    May 3, 2016
    Messages:
    107
    Likes Received:
    26
    Location:
    Northumberland
    Mine squeaks on bootup after that all appears as I'd expect. Similar issue? Something I should be concerned about?