Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

[Gimbal] I'm and idiot

Discussion in 'General Discussion' started by nperic, Feb 20, 2014.

  1. nperic

    Joined:
    Aug 23, 2013
    Messages:
    25
    Likes Received:
    0
    Location:
    Buenos Aires, Argentina
    Hello guys!

    I received this sunday a gimbal that was ready to use, calibrated and well configured. I read the instructions for more advanced users that had the links to download the simplebgc software and a driver, thinking that may be it was needed to enable the pitch with the phantom transmitter I installed everything.

    When I first supplied power to the gimbal with the phantom battery the camera went to the middle position and was working fine! I moved the phantom and the camera was all the time centered.

    The first time I connected the board in the simplebgc, all the parameters where like in the manual but I saw a red message indicating that the accelerometer needed calibration. And I pressed the calibration button overwritting the default configuration of the board and screwing everything up!

    Now the gimbal is going insane!

    I tried calibrating again the accelerometer following this video (http://www.youtube.com/watch?v=fNrUNJOb4tY) that explains how to do the six points calibration. Saved again the paremeters as in the manual but I can't get the gimbal working again.

    What I'm missing?? I don't know what to do with the gyro calibration :(

    Thanks in advance!!!
     
  2. Ton4

    Joined:
    Nov 28, 2013
    Messages:
    348
    Likes Received:
    1
    Don't need to anything with the gyro calibration, except for keeping things immovable while it calibrates. So after powering up your Phantom don't touch anything until the gimbal goes "into position".

    If you don't have the default configuration file for your gimbal, try to get one, load it up, press write and you should be back in business.

    If you do the accelerometer calibration, I give you my "recipe" : turn off the motors, lean the Phantom forward until the bottom of the gimbal lays flat on the table. Press the acc calibrate button, wait until the motors start again. Set Phantom back up straight.
     
  3. nperic

    Joined:
    Aug 23, 2013
    Messages:
    25
    Likes Received:
    0
    Location:
    Buenos Aires, Argentina
    Ton4, thanks for the reply.

    I don't have the default configuration file. The only thing that came with the gimbal were 3 pages with screenshots of the parameters in the simplebgc GUI.

    I'll try to get one, may I'll write to the manufacturer.

    Thanks!!
     
  4. Ton4

    Joined:
    Nov 28, 2013
    Messages:
    348
    Likes Received:
    1
    Ok, just connect the gimbal to the Phantom and you pc, turn off the motors of the gimbal, enter all the default values as in the screenshots, and press write. Finally do the acc calibration as above, and press write.

    If this doesn't work, they have supplied the wrong parameters I guess.