Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Gimbal control from transmitter

Discussion in 'Phantom 2 Help' started by xfusion, Mar 18, 2014.

  1. xfusion

    Joined:
    Mar 18, 2014
    Messages:
    4
    Likes Received:
    1
    so i'm trying to get my gimbal to roll with the lever on the back of the remote, i'm using the original phantom with a stock controller with the add-on lever on the back.
    [​IMG]

    and i setup everything via the naza assistant

    [​IMG]

    and i can see the x1 moving and i have already calibrated x1 in basic/RC on the assistant but i still have no movement on the gimbal..

    http://www.helipal.com/storm-sd-10-brushless-motor-gimbal-for-dji-phantom.html

    this is the gimbal i am using and i got into it via opensource software it runs and from what i can see, i have everything setup correctly
    [​IMG]

    i have pitch set to "rc_roll" because where the f2 connects to the gimbal its clearly labled on the board of the gimbal as "pitch" where it goes into, so its setup wrong..

    [​IMG]

    this is the best picture of that i can get, the 6 gold holes are where you would connect for "pitch" but! its wired to the "roll" side (the one a little further to the right on that picture) but either way, setting both to RC_ROLL should make it work, correct?

    also i have had conflicting information on which direction to plug in the roll cable on the NAZA-M, some say black on the top, yet everything seems to indicate, including the plastic connector, that it should be this way
    [​IMG]

    either way i have tried both ways, but still nothing.. any ideas on why i cant control the gimbal? or something to try to see? i have read that you need to upgrade the controller to get it to work but my controller does not have a USB on the board because its the phantom 1 controller and it looks like thats only a option for the phantom 2. Any help is help, thanks in advance
     
  2. RUSHNREADY DJI

    Joined:
    Mar 11, 2014
    Messages:
    175
    Likes Received:
    0
    have you tried connecting your remote ? and calibrating it ?
     
  3. xfusion

    Joined:
    Mar 18, 2014
    Messages:
    4
    Likes Received:
    1
    i cant phsically connect it since its a phantom 1 remote, there's no USB on the inside, but i have connected it via the phantom and calibrated it and it is working, at least from the controller->phantom it is seeing the lever movement
     
  4. RUSHNREADY DJI

    Joined:
    Mar 11, 2014
    Messages:
    175
    Likes Received:
    0
    I thought there was a connection on the inside of the remote ?
     
  5. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    The black cable does go on top when connecting to the NAZA, per the little diagram on the side of the module (right next to the F2 port label). If you first connected it the way you have in the pic above you were using the signal lead as the ground, and I can't say for sure what effect that might have on the gimbal board.
     
  6. mikeydaddio

    Joined:
    Feb 4, 2014
    Messages:
    166
    Likes Received:
    0
    Here are my settings which work. I think you definitely want pitch in the pitch parameter and not roll.

    Mike
     

    Attached Files: