Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. lentil

    Joined:
    Sep 13, 2016
    Messages:
    5
    Likes Received:
    2
    Howdy ,

    Long time listener first time caller ;)

    So when I fly my P4 and am trying to do Autonomous missions ie no hands on the sticks and let it do its own thing. The Mission starts off well and it flys to a few waypoints or follows the line and then it just wont complete the mission :(. sometimes on a way point and sometimes between waypoints ,it just hovers and starts to climb much higher than the original planned altitude (like from 30 to 100 Metres) and then I chicken out and bring it home.

    I am using both the Litchi App and the Drone Deploy App and I have used them in a number of configurations trying to work out whats happening,
    DJI Go app off completely
    DJI G to start an warm up plane but not launch
    Switching between apps

    Any one had this happen or have any tips to help me ?


    so far I have been flying by hand and getting some reasonable results but I really want to be able to add automated flying to improve my outputs.
    Screen Shot 2016-09-12 at 7.01.27 PM.png
     
  2. Jaye

    Joined:
    Aug 30, 2016
    Messages:
    6
    Likes Received:
    1
    No answer but I experienced something similar today. I got between waypoints 3 and 4 and my drone just stopped. Unlike you, though, I wasn't able to call it home. Luckily I could land it where it was safely. Maybe a Litchi glitch?
     
    lentil likes this.
  3. flyingphantoms

    Joined:
    Dec 13, 2016
    Messages:
    4
    Likes Received:
    0
    Having the same issue here with both DD and Litchi on my P4.
    With DD it usually occurs when I repeat a mission...(??).
    With Litchi I flew a couple POI focused w/ waypoints and a couple of Pano's the other day, no problem.
    Today I can't get any Litchi missions to complete whether downloaded from the hub or created on the fly on the tablet.

    With litchi it's just exactly as you describe. It flies to the 1st WP fine, then around the 2nd or 3rd WP it stops moving forward and just
    starts ascending. I've tried to out wait it hoping it would resume, but it doesn't (switch to sport, head home).
    I've run this scenario 16 times today. I update the P4 firmware. I created multiple mission plans, saved them reloaded them, changed altitudes and paths. The problem is obviously in the drone, but I tried a different phone/tablet anyway.

    DroneHealth isn't giving me any clues:
    ===========================================================
    Flight time Altitude Home Distance Type Notification
    A 00m 00s 6.6 ft 0 ft Mode Mode changed to GPS_Atti
    B 00m 44s 19.7 ft 11 ft Mode Mode changed to NaviGo
    C 01m 27s 95.8 ft 105 ft Mode Mode changed to Sport
    D 01m 42s 14.8 ft 5 ft Mode Mode changed to GPS_Atti
    ===========================================================
    Point A is the launch. Point B is engaging Litchi Mission. Point C is just past 2nd WP
    and starting to ascend, therefore I switch it to Sport mode.

    The craft should have stayed around 50ft. the whole mission.

    So far haven't found any useful tips on the Google...
     
  4. lentil

    Joined:
    Sep 13, 2016
    Messages:
    5
    Likes Received:
    2

    I found I had to cycle all the updates through both the machine and the controller and it fixed the errors I was having - DJI Phantom 4 – Specs, FAQ, Tutorials and Downloads

    I have been flying missions happy as a pig in Poo since then!!
     
  5. flyingphantoms

    Joined:
    Dec 13, 2016
    Messages:
    4
    Likes Received:
    0
    Well, you got my hopes up... But I've spent all day updating, downgrading, re-updating the bird, the RC, the batteries, 3 different tablet/phones, testing... still no luck.

    Thanks for the advice... it does seem like it's a firmware issue, but I haven't found the right combination of fixes yet...

    cheers--
     
  6. flyingphantoms

    Joined:
    Dec 13, 2016
    Messages:
    4
    Likes Received:
    0
    Finally!!! Just tried a couple of my test missions and they worked flawlessly!

    In case this helps anyone else, here is what I think caused and corrected my problem:
    • Ultimately it was a firmware issue - that seemed obvious after reviewing my steps, I just struggled to get a good update.
    • When I first got the message about a need to upgrade RC and MC firmware I was using my Galaxy Tab S2 - it upgraded the RC but not MC.
    • I think the/my Galaxy Tab S2 has a USB problem. I could not connect it to the drone via OTG cable - believe this caused the initial corrupt firmware.
    • Upgrading with the Assistant software appeared to complete successfully, but it did not - Not sure I like the assistant anymore...
    • After hours of downgrading, upgrading, testing, failing I was about to give up.
    • I decided to upgrade with DJI Go, but using my Nexus 9 tablet this time.
    The final upgrade with the Nexus 9 last night did the trick. Something I noticed that I had not seen in previous upgrades was after
    the drone reboot....

    On each previous upgrade attempt I received a successful completion message, then I rebooted the drone and went for a flight.
    This time I noticed that after the drone reboot and reconnecting the RC & tablet I got another "Successful Upgrade" message as
    soon as the DJI Go app connected to the drone.... This seems to be a key... for me at least.

    So from now on I will:
    • Use the DJI Go app to perform the upgrade (Will not use my Galaxy Tab S2)
    • Make sure I get another "Successful Upgrade" message in DJI Go app after I reboot the drone and reconnect the RC & tablet for first time after an upgrade.
    cheers