Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Downgrade 1.0.8

Discussion in 'Phantom 2 Discussion' started by FredzMaxxUAV, Mar 11, 2016.

  1. FredzMaxxUAV

    Approved Vendor

    Joined:
    Jun 25, 2015
    Messages:
    566
    Likes Received:
    121
    Is it somehow still possible to downgrade a new Phantom 2 (latest firmware, not Vision) to 1.0.8 (or 2.0)?

    I found DJI Assistant 1.0.8, but the question is: does it still work (I'm getting a network error, but I don't have a P2 yet), and also, can it still be used to downgrade 3.x?
     
    #1 FredzMaxxUAV, Mar 11, 2016
    Last edited: Mar 11, 2016
  2. gppms

    Joined:
    Mar 12, 2014
    Messages:
    236
    Likes Received:
    35
    Location:
    Greece.
    Unfortunately you can't downgrade to older firmwares. Dji has remove them from their servers and the only available firmware is the latest one only.
     
  3. pinchers

    Joined:
    Aug 29, 2015
    Messages:
    19
    Likes Received:
    4
    I had a similar problem which was driving me mad and then found out that the mini USB Cable I was using was defective, after i replaced it all was well and still is.