Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Does the Quad and the TX have to be on the same update?

Discussion in 'Pro/Adv Discussion' started by keving, Mar 18, 2016.

  1. keving

    Joined:
    Mar 14, 2016
    Messages:
    2
    Likes Received:
    0
    I just purchased a P3P, and i can only connect my Android phone to the DJIGo ap. I have an iPad that wil not connect and I am looking for a solution.

    In the Android app DJI Go, I see there are 2 versions of FW listed.
    Version 1.6.40
    Remote Controller 1.5.40

    Should I update the TX to 1.6.4 or newer? I am not sure if this will change how the iPad connects, but this is what I am trying to get fixed. Unit flies great w/ my Android.
     
  2. Air Ontario

    Joined:
    Jan 11, 2016
    Messages:
    1,271
    Likes Received:
    493
    Location:
    U.S./ Canada
    No don't have to be same version. My p3p is rc 1.57 and bird on 1.7 if I remember the #s correctly after this recent update. Im on iOS however.

    In fact before updating dji go app and firmware on RC and bird, my versions were the same as you have.
     
  3. keving

    Joined:
    Mar 14, 2016
    Messages:
    2
    Likes Received:
    0
    Thank you for the info.

    I just tried an iPad Mini and it connects. Can not figure out why my iPad will not connect.

    It is an older iPad, but it is on IOS 9xx.
     
  4. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,724
    Likes Received:
    3,440
    You might be out of luck there.
    The app is very processor hungry and the older processors aren't up to it.
     
  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,864
    Likes Received:
    5,558
    Location:
    US
    It would be best to use a device from this list.