Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Advanced DJI GO

Discussion in 'Phantom 3 Help' started by guards, Aug 18, 2015.

  1. guards

    Joined:
    Apr 1, 2014
    Messages:
    21
    Likes Received:
    1
    Location:
    Regina Canada
    can DJI GO update app on nexus 7 2013 be used with android version 1.2.8 on the phantom 3 advance & controller , or do you have to update phantom & controller to latest firmware.to be compatible, I have been using 1.1.0 on the nexus till now, thank you very much for any info that you can give me guards
     
    #1 guards, Aug 18, 2015
    Last edited: Aug 18, 2015
  2. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,376
    Location:
    Live! From New York!
    Android Version v2.0.0. requires Android 4.1.2 or later. Compatible with Samsung tabs 705c, Samsung S6, Samsung S5, Samsung NOTE4, Samsung NOTE3, Google Nexus 9, Google Nexus 7 II, Ascend Mate7, Nubia Z7 mini, SONY Z3 EXPERIA, MI 3, MI PAD.
     
  3. Memtenn60

    Joined:
    Dec 28, 2013
    Messages:
    118
    Likes Received:
    10
    Oh Great ! How about the Nvidia Shield? I hope they didn't forget that. I bought a new one because my iPhone 5 and iPad 2 were not compatible with firmware when I bought my P3P
     
  4. tcope

    Joined:
    Jan 29, 2015
    Messages:
    3,533
    Likes Received:
    1,390
    Location:
    Salt Lake City, UT
    Go runs fine on the Shield.
     
  5. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,376
    Location:
    Live! From New York!
    There is a side note that says they will add more as they test them. I believe there are quite a few here that are using the Shield with success.
     
  6. guards

    Joined:
    Apr 1, 2014
    Messages:
    21
    Likes Received:
    1
    Location:
    Regina Canada
    i am very sorry I shoud have explained my question more clearly,.I have a nexus 7 2013 with the 1.1.0 app on it, I would like to know if I update to DJI go app if I can use firmware 1.2.8 on my phantom 3 advance, thanks very much for any help I can get ,very sorry for my poor post guards
     
  7. Memtenn60

    Joined:
    Dec 28, 2013
    Messages:
    118
    Likes Received:
    10
    Trope, thanks for info on Shield
     
  8. kdrak

    Joined:
    Jun 22, 2015
    Messages:
    137
    Likes Received:
    27
    I have updated my android device to DJI GO 2.0.1 and connected successfully my P3A WITH 1.2.8 firmware . I have never tried to fly and finally I updated the aircraft to the latest firmware1.3.20