Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI Go app resets video stream mid-flight?

Discussion in 'Pro/Adv Discussion' started by dmehinovic92, Jul 30, 2016.

  1. dmehinovic92

    Joined:
    Jun 10, 2016
    Messages:
    33
    Likes Received:
    2
    Location:
    Phoenix, Arizona
    Hey guys!

    I've got a P3P and while I was flying today, still within very visible sight, my DJI Go feed turned dark and then just said DJI on the screen until the video came back. After the video came back but I had to turn the gimbal dial to reset the image brightness. Has this happened to anybody and is there a fix?

    Thank you for any help and suggestion!


    Sent from my iPhone using PhantomPilots mobile app
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,073
    Likes Received:
    5,619
    Location:
    US
    There aren't too many posts about that problem here or on the DJI forum. Try these things:

    1) Reinstall DJI GO.
    2) Format your memory card in DJI GO.
    3) Visually inspect the camera that connect to your gimbal/camera to see if any of them appear to be damaged.
     
  3. dmehinovic92

    Joined:
    Jun 10, 2016
    Messages:
    33
    Likes Received:
    2
    Location:
    Phoenix, Arizona
    Hey do you have a link of what the connections are supposed to look like and which ones I need to check? I've tried the first two parts and no luck.


    Sent from my iPhone using PhantomPilots mobile app
     
  4. dmehinovic92

    Joined:
    Jun 10, 2016
    Messages:
    33
    Likes Received:
    2
    Location:
    Phoenix, Arizona
    So i have discovered that when this issue happens, my DJI Go app says the Gimbal is Disconnected on overall status. Here are a few screenshots of what it shows on my app.
     

    Attached Files:

  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,073
    Likes Received:
    5,619
    Location:
    US
    Since you're seeing the gimbal disconnected message, check the cables going into the top of the gimbal:

    113936thnhak0zckkrhgqa.jpg

    Make sure they are not visually damaged (frayed, crimped, etc.). If they look okay, remove the plugs and plug them back in to ensure they are fully seated.
     
    ullhan84 likes this.
  6. dmehinovic92

    Joined:
    Jun 10, 2016
    Messages:
    33
    Likes Received:
    2
    Location:
    Phoenix, Arizona
    I did that last night but I haven't tested it yet. Can it also be an issue with the ribbon cables?



    Sent from my iPhone using PhantomPilots mobile app
     
  7. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,073
    Likes Received:
    5,619
    Location:
    US
    Your Phantom is indicating that it cannot find the gimbal, so I'd don't think the issue is the ribbon cable (since that connects the camera to the gimbal).
     
  8. dmehinovic92

    Joined:
    Jun 10, 2016
    Messages:
    33
    Likes Received:
    2
    Location:
    Phoenix, Arizona
    Yeah I just tested it now and it resets whenever I go to take a photo and when I switch over to video. I looked at all the cables and everything checks out fine. I honestly think I just have a bad gimbal overall. And I don't know what to do at this point.


    Sent from my iPhone using PhantomPilots mobile app
     
  9. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,073
    Likes Received:
    5,619
    Location:
    US
    Did you see this issue before upgrading the firmware?
     
  10. dmehinovic92

    Joined:
    Jun 10, 2016
    Messages:
    33
    Likes Received:
    2
    Location:
    Phoenix, Arizona
    Not that I remember. But I didn't test out the video recording when I tested the drone itself.


    Sent from my iPhone using PhantomPilots mobile app
     
  11. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,073
    Likes Received:
    5,619
    Location:
    US
    I'm wondering if it was occurring before you upgraded.

    Here are a few things you could try:

    1) Reinstall the current firmware (like this).
    2) Downgrade to the previous firmware version and see if the problem still exists.

    If neither of the above fix the problem, then it's likely a hardware issue that you'll need to get fixed somewhere.
     
  12. dmehinovic92

    Joined:
    Jun 10, 2016
    Messages:
    33
    Likes Received:
    2
    Location:
    Phoenix, Arizona
    Thanks I will try to downgrade it and see what happens. Crappy thing is I don't have the original proof of purchase so I can't even check for warranty. But I'll try to see what happens. Thank you for your help!


    Sent from my iPhone using PhantomPilots mobile app
     
  13. dmehinovic92

    Joined:
    Jun 10, 2016
    Messages:
    33
    Likes Received:
    2
    Location:
    Phoenix, Arizona
    Just an update, i went ahead and tried reinstalling the firmware and then i tried downgrading and the problem was still the same, if not even worse. With the downgraded firmware, as soon as i even opened the camera view, it would shut me down. But wit the most updated fw, it would shut me down when i go into the camera settings. I guess it will be going to the closest repair shop once i get some money put together. Thanks for your help!
     
  14. brhodz

    Joined:
    Dec 4, 2015
    Messages:
    74
    Likes Received:
    6
    On my p3p I have the same type of problem. Butt no gimbal message like you have I don't think or ever noticed.. I actually can take pics record and view photos like it should just no video. just that black dji screen Butt if I move the camera roller button up/downup/down kinda quickly right at the time video usually appears on go app .then usually Ill have video.. sumtimes I have to restart over and over till it shows video.. sumtimes I don't even restart it I just rip out battery and jam battery back in , if it gets to that point and I do it till it works.... butt sumtimes no trouble ..


    Sent from my XT1585 using PhantomPilots mobile app