Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional DJI Go APP lost communications while flying

Discussion in 'Phantom 3 Help' started by MichaelT1960, Aug 31, 2015.

  1. MichaelT1960

    Joined:
    May 31, 2015
    Messages:
    28
    Likes Received:
    1
    I was up tonight flying around at 400' (300') away and returning home when the APP said it lost communications. The SAT signal was empty but clearly I was still in full control using my RC. I believe even the middle top turned to red and said disconnected! .....Then all was well again and everything was fine. I doubt I never lost the SAT communications either....

    This hasn't been the first time this has happened but when it does it makes me nervous! Why is this happening....is it a bug in the DJI GO APP?

    Also when I first fired the P3 up the APP said "Update required" with a red triangle and that eventually went away. As far as I know I already have the latest updates.

    Any help would be appreciated!

    Michael
     
  2. Farmer

    Joined:
    Jan 25, 2015
    Messages:
    140
    Likes Received:
    38
    Location:
    Northland, New Zealand
    Same thing just happened to me.
    Prior to taking off the app could not connect to P3.
    I regained communication but could not get video or camera to work.
     
  3. Farmer

    Joined:
    Jan 25, 2015
    Messages:
    140
    Likes Received:
    38
    Location:
    Northland, New Zealand
    Oh.found it.my sd micro card was corrupted. reformatted.
     
  4. aopisa

    Joined:
    Aug 30, 2015
    Messages:
    76
    Likes Received:
    23
    There seems to be a marked increase of these type of reports lately. Happened to me for the first time yesterday.

    Took several tries of shutting things down and rebooting before the issue was resolved.
     
Loading...