Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

DJI crashes after take off

Discussion in 'Phantom 1 Help' started by JIGIoutdoor, Dec 6, 2013.

  1. JIGIoutdoor

    Joined:
    Oct 12, 2013
    Messages:
    11
    Likes Received:
    0
  2. discv

    Joined:
    May 7, 2013
    Messages:
    619
    Likes Received:
    26
    Location:
    London, UK
    I guess that is in ATTI mode. Wonder if the same fault exists in manual mode. This might narrow down the problem.
     
  3. tanasit

    Joined:
    Jan 28, 2013
    Messages:
    554
    Likes Received:
    2
    So far, I can only come up with 2 suggestions:

    1. Double check your props if they are properly installed on the correct arm.
    2. Take off very slowly in manual mode, it it lift off a foot or less without any oscillations, then you will have to do all the calibrations which include: tx (by itself); compass, IMU.

    Good luck
     
  4. netphreak

    Joined:
    Sep 17, 2013
    Messages:
    228
    Likes Received:
    0
    Have you recently updated the firmware? Did you remember to import the default configuration parameters afterwards?
     
  5. Hiway

    Joined:
    Nov 28, 2013
    Messages:
    491
    Likes Received:
    2
    My first thought too... I think the props are on right as it lifts... but the balance and harmony is all wrong.

    Default configurations need to be imported I bet. Wish I could attach files- I would post it.

    Zip file is here- last one down: http://www.dji.com/download/phantom-downloads/
     
  6. JIGIoutdoor

    Joined:
    Oct 12, 2013
    Messages:
    11
    Likes Received:
    0
    im going to check it all and let you guys know if it flies or not... thank you for you help.
     
  7. JIGIoutdoor

    Joined:
    Oct 12, 2013
    Messages:
    11
    Likes Received:
    0
    So, my dji acted like that 2 weeks ago. I am 99.9% sure the propeller were properly set. I hooked it in the computer and it showed every thing normal. Than I packed it for two weeks.
    After traveling half the world in two weeks I came home and reassembled the DJI. Calibrated it, leveled the compass and started it. IT RAN AS SMOOTH AS IT USED TO.
    So, I still have no idea what happened to it and how it got fixed. The question is that;
    Calibration fixed it?
    Compass fixed it?
    Or what?