Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Configure P2 flight for Futaba/Walkera through SBUS

Discussion in 'Phantom 2 Help' started by The Phantom, Sep 8, 2016.

  1. The Phantom

    Joined:
    Jul 25, 2014
    Messages:
    159
    Likes Received:
    2
    Location:
    Europe
    I have trying to configure my Walkera F12E transmitter to use it with the Phantom 2, i am using a signal converter module since the Walkera doesn't have SBUS and the P2 flight controller only takes SBUS receivers.

    Anyway in the P2 software i have set a switch as the flight modes switch, but when i toggle the switch it just changes between the Failsafe, atti and the mode you can chose yourself all the way to the right.
    The problem is that the when i toggle the switch it doesn't go all way to the left to GPS, so in other words i can't chose GPS mode as one of my preferred flight modes since the switch aint going all the way there.
    Does anybody know how to change that so it goes all the way to the left to GPS?

    Also i can't start the engines with the start engines command, and not by any other stick kombination either?

    I guess this problem is not specific to Walkera but can happen with Futabas and other brands as well.
    Help would be much appreciated.
     
  2. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,107
    Likes Received:
    405
    Location:
    Commerce Twp,MI
    I may be wrong but my understanding is if anyone is going to use a transmitter other then a DJ6 or NDJ6 they have to remove the DJI receiver and replace it with a compatible receiver for the TX.
     
  3. The Phantom

    Joined:
    Jul 25, 2014
    Messages:
    159
    Likes Received:
    2
    Location:
    Europe
    Yes i have changed the receiver to the Walkera receiver.

    But i found the solution, it was the End point / Travel adjustments setting that needed to be fine tuned in the transmitter.