Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

cant take video or pics with new firmware?????Need help

Discussion in 'Pro/Adv Discussion' started by Ross Gerami, Nov 5, 2015.

  1. Ross Gerami

    Joined:
    Jul 31, 2015
    Messages:
    15
    Likes Received:
    1
    I just received my PH3 from DJI after repairs and I then downloaded updated firmware liked it asked and now I cant take video or pics because screen gone's black when I press pics or video. I have Ios 9.1 on my I Pad is that the problem that it's not compatible? I have App 2.4.0,RC 1.4.30, aircraft 1.4.10
    Need help
     
  2. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,744
    Likes Received:
    1,092
    Location:
    Long Island, NY
    try rebinding your controller.
     
  3. RedHotPoker

    Joined:
    May 3, 2015
    Messages:
    3,972
    Likes Received:
    1,365
    Location:
    Edmonton Alberta
    Which version of iPad are you using?
    Update your iPad to the latest iOS, 9.0.2

    RedHotPoker
     
  4. IBeSnoopy

    Joined:
    Oct 28, 2015
    Messages:
    24
    Likes Received:
    17
    Location:
    Utah
    I have the IPad Mini with IOS 9.1 with the latest firmware and all is working good. I updated the IPad Mini last night to 9.0.2 and all is still working as expected. I would try rebinding and if that doesn't fix it then remove the app and re-install it again.
     
  5. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,526
    Likes Received:
    1,477
    Location:
    Sacramento CA
    You went from 9.1 (latest) to 9.02?
     
  6. IBeSnoopy

    Joined:
    Oct 28, 2015
    Messages:
    24
    Likes Received:
    17
    Location:
    Utah
    Sorry I meant the other way. My bad. I just upgraded the mini to the latest IOS. My next door neighbor did the same and ended up reinstalling the application to get his working again.
     
    Oso likes this.
  7. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,526
    Likes Received:
    1,477
    Location:
    Sacramento CA
    Same question as @RedHotPoker asked. Which iPad are you using?

    If it's too old, it may not be powerful enough. Unfortunately, with GO 2.4 older devices have been able to download the app without getting the "not compatible" message that older devices used to get. (See this thread for info). Perhaps an older device is your issue?
     
  8. Poundofnuts

    Joined:
    Jul 6, 2015
    Messages:
    208
    Likes Received:
    34
    Join the rest of us. The latest firmware and software upgrades have been a total sh!t show and grounded most of us.
     
  9. RedHotPoker

    Joined:
    May 3, 2015
    Messages:
    3,972
    Likes Received:
    1,365
    Location:
    Edmonton Alberta
    I've Never had any problems from day one!
    So not sure about your flying group. Thankfully, it's not everyone, just some of you, with Phantom pains and issues. ;-)

    RedHotPoker