Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Can't get my new Futaba Radio to be recognized

Discussion in 'Phantom 1 Help' started by GeneL, Aug 30, 2013.

  1. GeneL

    Joined:
    Apr 19, 2013
    Messages:
    104
    Likes Received:
    1
    Location:
    Northern California
    After looking at Richard Whelan's videos, I thought that installing my new Futaba T8J would be about as close to plug and play as possible, but somehow I managed to mess it up.

    Simply, when I plug in the Futaba receiver, it doesn't seem to be recognized by the Phantom. The LED blinks continuously just as it would when the transmitter is turned off. Of course, I'm careful to turn on the transmitter first, then power up the Phantom, but I always get the same result. When I plug the S-Bus cable back into the Phantom receiver, everything appears normal again. Here are the facts as best I know:

    *I paired the Tx and Rx, and the light is green on the Rx as the instructions say should be if they are paired. I assumed they would be paired from the factory, but have done it a couple of extra times just to be sure.
    *The Phantom LED blinks continuously when the Futaba Rx. is plugged in (Tx turned on).
    *The LED (and assistant screens) are normal when I plug the S-Bus cable back into the Phantom Rx.

    From the video, it didn't seem like there was any extra setup necessary to get the Futaba Rx recognized. I figured that I should have that settled before I go to the rest of his instructions dealing with getting the switches for IOC and GPS modes set up correctly.

    Is there any setup of the Tx required just to get the Futaba system recognized by the Phantom?

    On top of that, I think I may have compromised one of the wires on the S-Bus cable, but that's another matter. It works OK with the stock Tx/Rx, even though I don't fully trust it now and am trying to find another one.

    Please, anyone, do you have ideas on why I can't get the Futaba going?
     
  2. Nwales

    Joined:
    Jul 28, 2013
    Messages:
    94
    Likes Received:
    0
    Location:
    Wales uk
    Did you change the tx settings in naza assistant ? The stock tx is set too PPM , you need to change that too D-Bus .

    Then don't forget to re calibrate the futaba :D
     
  3. marcus_canada

    Joined:
    Jul 22, 2013
    Messages:
    304
    Likes Received:
    4
    Ok, you don't trust the S-Bus cable anyway? I would suggest your problem is with the PPM/D-Bus mode selection but the S-Bus cable is pretty important to the operation LOL
     
  4. GeneL

    Joined:
    Apr 19, 2013
    Messages:
    104
    Likes Received:
    1
    Location:
    Northern California
    Thanks for the help, folks. Since I got back to the forum and check in here I figured it out and had done what you said.

    I didn't mean I don't like S-Bus - it's just that I think I may have pulled one or more of the little wires loose getting it out of the stock Rx, so I couldn't trust it not to come disconnected in the air. When I got everything working right I piled thick glue around the junction of wires and connector to keep them from ever moving, so as long as the connection is good now, I don't think its going anywhere.

    Also, having the variable knob to adjust the tilt on the Zenmuse is pretty exciting! I finally managed to get it calibrated in the Assistant by following directions for the X1 channel. I don't know what the heck the Zenmuse assistant is for, then, because it only has one part - a slider for the tilt - and it doesn't do anything. As far as I can see, the calibration is all done through the Naza assistant, at least using the Futaba S-Bus system.

    My last setup challenge is to unearth the post I saw about assigning one toggle switch to temporarily cut back the yaw gain for steady, slow pans.

    Again, thanks for posting.