Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Cannot Calibrate Compass (Disconnected)

Discussion in 'Phantom 3 Help' started by Flipsonic, Jun 12, 2016.

  1. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    Just got my P3P and trying to fly for the first time. I'm using a HTC One Plus M8 with Android 4.4.2 and latest DJI Go app. Green light on the RC and P3P is blinking green 2X. Looks to be a GPS issue. But as you can see on the 2nd pic below, it knows where I am since the location is correct. Cannot calibrate the P3P compass because it is disconnected. Poor signal. See attached pics. I'm outside at my backyard with a good view of the sky but can't see any GPS. Do I need to wait for a while to lock on to GPS for the first time? Do I need to update firmware of RC and P3P? The app didn't ask to do this. I thought it should ask to do it automatically. Any help would be appreciated. Thanks.
     

    Attached Files:

    #1 Flipsonic, Jun 12, 2016
    Last edited: Jun 12, 2016
  2. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    Update: Chatted with DJI online support and they said to use an iPhone instead. DJI website says HTC One is approved. Also they said I need to activate the drone. How come that is not in the quick start guide? When I turned everything on for the first time and launched DJI Go app, it didn't take me through the activation and firmware upgrade process. All I got on the app are the 2 pics attached above. I tried activating but not successful.
     
    #2 Flipsonic, Jun 12, 2016
    Last edited: Jun 12, 2016
  3. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,759
    Likes Received:
    3,469
    You mentioned the Quick start guide but not the manual.
    If you haven't got that, it's here: https://dl.djicdn.com/downloads/phantom_3/en/Phantom_3_Professional_User_Manual_en_v1.8_160330.pdf

    Your compass is unrelated to GPS. You don't need to be concerned about GPS when you are calibrating the compass.
    The important point when calibrating the compass is that you do it well away from any steel objects or electromagnetic fields.
    So don't try near a car, on reinforced concrete or near electric cables.
    If you are having trouble getting to activate, try pulling the cable and reconnecting and see if that prompts it.

    As for DJI support advice, unfortunately they are not very reliable.
    The suggestion that you use an iPhone rather than your HTC One sounds dubious.
    Half the flyers out there use Android devices quite happily.
     
  4. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    Thanks. I do have an e copy of the manual. Why is my phone disconnected to my P3P? I remember putting my phone on airplane mode but left WiFi on. I read this is a good idea in case you get a call and may disconnect during flight. Is that true? Won't airplane mode turn off GPS? I will try in the morning by leaving airplane mode off. See if that makes any difference.
     
    #4 Flipsonic, Jun 12, 2016
    Last edited: Jun 12, 2016
  5. Meta4

    Meta4 Moderator
    Staff Member

    Joined:
    Jan 8, 2014
    Messages:
    7,759
    Likes Received:
    3,469
    Airplane mode doesn't turn off GPS ... but you only need a GPS in your phone for follow-me flight or resetting your home position to the current location of the controller.
    For all normal flight, the only GPS your Phantom uses, is the one built in to the Phantom.
    Airplane mode on or off should make no difference to the Phantom and your flying.
    If you did get a call, that should not disconnect the app, but even if it did, you still should have full control still.
    Don't bother with firmware updates until you have the basics sorted out
     
  6. Flipsonic

    Joined:
    Jun 8, 2016
    Messages:
    321
    Likes Received:
    75
    Location:
    San Francisco Bay Area
    The problem looks to be the HTC One. You're right, airplane mode or not it doesn't matter. I used a Galaxy S6 and it fires right up. Hmmm...I remember seeing HTC One as an approved device. Gonna have to call DJI about it. In the meantime, at least I get to have fun this morning.