Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

cannot bind after rebuild

Discussion in 'Phantom 2 Vision + Help' started by Gary Beamon, Dec 25, 2015.

  1. Gary Beamon

    Joined:
    Dec 25, 2015
    Messages:
    26
    Likes Received:
    0
    hey guys

    in need of some help

    had a new shell painted for me so sat down yesterday and took the insides out of my phantom and fitted into the new shell also had a new compass leg, so both legs and shell match colour, anyway after rebuild all was well then .....

    today turned the phantom on and its flashing yellow lost rc signal tried tons of times pressing the buttom on the side of the phantom to rebind the TX but its having none of it had it plugged in to PC but thats not picking up the TX either so I cant calibrate

    what should I do

    cheers

    and merry christmas
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,832
    Likes Received:
    5,545
    Location:
    US
    Are you pushing the button and doing nothing else after that? If so, you're missing a few steps. See more details here.
     
  3. Gary Beamon

    Joined:
    Dec 25, 2015
    Messages:
    26
    Likes Received:
    0
    Great post buddy will go try that in a second thank you
     
  4. Gary Beamon

    Joined:
    Dec 25, 2015
    Messages:
    26
    Likes Received:
    0
    No cant do that on my dji app the app says to press the button on the side of the craft and then turn on the tx but it's not working for me

    Another note when you go to the camera on the app it says signal lost in the top right and in centre screen says mc configuration error reboot required ??? Any ideas guys shall I order a new receiver board
     
  5. Gary Beamon

    Joined:
    Dec 25, 2015
    Messages:
    26
    Likes Received:
    0
    sorted it today guys, new Rx fitted binded straight away then had to calibrate everything now its good to go fly