Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Battery Issue/Question

Discussion in 'Phantom 2 Vision + Discussion' started by Trion, Dec 4, 2014.

  1. Trion

    Joined:
    Aug 24, 2014
    Messages:
    3
    Likes Received:
    0
    I have 3 OEM batteries for my Vision + and use nothing but the original charger on them. Yesterday decided to fly so I charged the batteries and placed #1 in vision. Showed 100%, got GPS and home lock and started flying. Battery went to 90% very rapidly, but still showed 18 minutes of flight time on the app. Within 2 minutes the battery had dropped to 50% and another minute later my vision was trying to self-decend because my battery was now showing 19%. Likely I was near where I started and was able to catch it before "the ground did". After this I put #2 battery in and it lasted and fly like normal, roughly 18 minute flight time, then put #3 battery in, and it acted exactly the same as #1. Placed 1 and 3 on the charger and proceeded to charge correctly, then used them while hooked up to the computer and they both showed less then 20 charge cycles and showed as being balanced.

    All were purchased at the same time, and stored and charged the same way. I am using the latest firmware and updates on everything. Are the batteries "junk" or is there something I can do to try and restore them?
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,924
    Likes Received:
    5,573
    Location:
    US
    Did you try to recharge them and see if you could repeat that process? That would be the first thing to try.
     
  3. Trion

    Joined:
    Aug 24, 2014
    Messages:
    3
    Likes Received:
    0
    I have repeated the process and the same thing -- both #1 & 3 both lost their charge within 5 minutes of flying.
     
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,924
    Likes Received:
    5,573
    Location:
    US
    And, when you updated your firmware, did you swap out each battery and rerun the updates in the Vision Assistant software? Each battery needs to be updated separately.
     
  5. Trion

    Joined:
    Aug 24, 2014
    Messages:
    3
    Likes Received:
    0
    don't think I did that will try and post results,
     
  6. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    18,924
    Likes Received:
    5,573
    Location:
    US
    You'll need to go into the "Upgrade" section and manually start the update to install the battery firmware.