Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

After almost a year without problems.....

Discussion in 'Phantom 2 Vision + Discussion' started by Elginet, Dec 4, 2014.

  1. Elginet

    Joined:
    Dec 16, 2013
    Messages:
    178
    Likes Received:
    1
    Location:
    Illinois
    I went to launch my P2V+ this morning and it would take off....but then land itself while the warning honked on the pad. I changed batteries, same thing. This was a once-a-year event I was suppose to get aerials of.....and couldn't. WTF did DJI do to my aircraft?

    Yes....everything is up to date. Yes....Compass calibrated fine. All switches were in the up position. I have about 150 hours flying this particular Phantom. Never an issue. I do the updates and boom....doesn't work.

    I'm pissed.
     
  2. Monte55

    Joined:
    Apr 26, 2014
    Messages:
    2,200
    Likes Received:
    517
    Location:
    Raymore Missouri
    If you had a working quad with no problems and had an important thing to do....why would you upgrade now? Just curious. I got my Phantom in April 2014. I haven't upgraded the software and I don't have any problems. As sure as I do...I will....
     
  3. Mopar Bob

    Joined:
    Oct 5, 2014
    Messages:
    219
    Likes Received:
    2
    Location:
    Connecticut, USA
    We have all had our share of problems caused by DJI's upgrades. I have two that I am still trying to work out. BUT, before condemning DJI any further, check to see if you are trying to fly in one of the no-fly zones (near an airfield for instance).
     
  4. Fplvert

    Joined:
    May 28, 2014
    Messages:
    1,559
    Likes Received:
    708
    Location:
    Southern Idaho USA
    :cry:
    How frustrating!
    I'm with Monte55 on this one. With all the problems other pilots reported with the updates, I'm definitely not plugging my bird into oblivion. Maybe you can "upgrade" back to the firmware that worked for you?
     
  5. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,096
    Likes Received:
    5,623
    Location:
    US
    What exactly was the warning telling you?
     
  6. BlackTracer

    Joined:
    Mar 29, 2014
    Messages:
    980
    Likes Received:
    22
    Location:
    Winter Park, FL USA
    Had to be low batt since that is the honk inducing condition that autolands. I havent and am not going to do this upgrade, cause I don't need it. I don't think lol.
     
  7. Elginet

    Joined:
    Dec 16, 2013
    Messages:
    178
    Likes Received:
    1
    Location:
    Illinois
    Both batteries were over 95%. that's what was confusing me. The Battery indicator on the app was flashing red too. This happened too while on my way back from Salt Lake City last week. I was out in the country and saw a perfect aerial shot, got the Phantom out, fired it up and same thing happened. Replaced the battery and tried again. Same thing. I was still a thousand miles from home without a computer to toss it on. I thought it may have had something to do with an updated app not being able to control the quad without updating the P2V, so I packed it up. I upgraded the software because I thought that it had had something to do with this and since this was a public event, didn't want to take a chance on anything going wrong.

    Airspace? I'm a pilot. I was nowhere near an airport. It was out in the country. No comm or cell towers around. Actually the perfect flying conditions.

    Compass calibration appeared to be attained normally as in any other flight. No indicators, weird lights flashing...nothing.....until I launched it.

    Oh well. Went through everything again. Checked all my batteries. Everything's showing fine. i've rotated through 4 batteries since getting it, but have actually probably put over 150 hours of actual flight time on it.
     
  8. Mopar Bob

    Joined:
    Oct 5, 2014
    Messages:
    219
    Likes Received:
    2
    Location:
    Connecticut, USA
    Did you try an IMU calibration after the updates? Someone suggested a basic then an advanced calibration some time ago which made a difference for me.
     
  9. kenargo

    Approved Vendor

    Joined:
    Nov 20, 2014
    Messages:
    461
    Likes Received:
    60
    So far, and I hope I don't jinx myself by saying I've never had issues with any update (knock very hard on wood)!

    I always follow the same procedure. I update everything, power cycle everything and then calibrate everything; RC Assist App and Vision Assist App. RC, IMU, etc. Maybe one day it will bite me for doing it, maybe I should allow other people to work out the bugs first, maybe I've been lucky so far and should start buying lotto tickets.

    The battery issue, I understand was that older batteries suddenly started reporting bad cells and the recent update (last week I think) was said to fix it for most people. Is it the most recent update that caused your issues or the one before that? Just curious.

    Hope you get back in flight soon.
     
  10. Dom

    Dom

    Joined:
    Oct 11, 2014
    Messages:
    10
    Likes Received:
    0
    I recently went through the same thing after an update. The only fix was to delete the DJI apps from the pad & computer both. Then I went to the DJI web sight and downloaded everything again and everything worked as it should. I hope this helps.
     
  11. Skynet1

    Joined:
    Apr 20, 2014
    Messages:
    192
    Likes Received:
    12
    My understanding, as it relates to battery issues is that the connection pins on the quad can weaken over time, particularly in the case where the battery is left in the quad for extended periods of time.
    I suspect a weakening or loss of spring tension of those pins can cause poor connection with the battery. This may occur with quads that have a lot of flight Hrs. on them would be my guess. Ultimately this may create invalid info. being interpreted, and a low battery message etc. to follow.
    As a perquisite I like to use a product (CRC 2-26), an electrical grade lubricant which is plastic safe, and enhances electrical properties. A small amount sprayed onto both the contact pins and blade connectors within the quad, as well as on the small round contacts located on the battery itself May help resolve the issue.
     
  12. DBS

    DBS

    Joined:
    Apr 6, 2014
    Messages:
    1,187
    Likes Received:
    163
    Location:
    Ft. Pierce, Florida
    This sounds suspiciously like dirty data pins on the battery connectors...

    Both batteries... same thing... same day... :?
     
  13. Iabove

    Joined:
    Nov 30, 2014
    Messages:
    73
    Likes Received:
    1
    I know mine didn't start up at all until I didn't advance calibration on computer hope you get it back up and going
     
  14. TomWolves

    Joined:
    Jul 14, 2014
    Messages:
    138
    Likes Received:
    9
    What is power cycle,and how do you go about that procedure ?
     
  15. Mopar Bob

    Joined:
    Oct 5, 2014
    Messages:
    219
    Likes Received:
    2
    Location:
    Connecticut, USA
    You turn the phantom power switch off then back on again.
     
  16. Jetfixer

    Joined:
    Jun 20, 2014
    Messages:
    48
    Likes Received:
    1
    It probably is software or firmware related, but check and clean the battery contacts in the Phantom and on the batteries.
     
  17. Skynet1

    Joined:
    Apr 20, 2014
    Messages:
    192
    Likes Received:
    12
    Had to be low batt since that is the honk inducing condition that autolands. I havent and am not going to do this upgrade, cause I don't need it. I don't think lol.[/quote]

    Both batteries were over 95%. that's what was confusing me. The Battery indicator on the app was flashing red too. This happened too while on my way back from Salt Lake City last week. I was out in the country and saw a perfect aerial shot, got the Phantom out, fired it up and same thing happened. Replaced the battery and tried again. Same thing. I was still a thousand miles from home without a computer to toss it on. I thought it may have had something to do with an updated app not being able to control the quad without updating the P2V, so I packed it up. I upgraded the software because I thought that it had had something to do with this and since this was a public event, didn't want to take a chance on anything going wrong.

    Airspace? I'm a pilot. I was nowhere near an airport. It was out in the country. No comm or cell towers around. Actually the perfect flying conditions.

    Compass calibration appeared to be attained normally as in any other flight. No indicators, weird lights flashing...nothing.....until I launched it.

    Oh well. Went through everything again. Checked all my batteries. Everything's showing fine. i've rotated through 4 batteries since getting it, but have actually probably put over 150 hours of actual flight time on it.[/quote]

    viewtopic.php?f=27&t=30092&start=10

     
  18. Elginet

    Joined:
    Dec 16, 2013
    Messages:
    178
    Likes Received:
    1
    Location:
    Illinois
    Getting really pissed now. Battery terminals are fine. I just went out and flew 4 batteries to death. 1 of them, showed a full charge. As soon as I took off and attempted to climb, it started honking and when looking at the app, said batter was now at 17%! less than 2 minutes in the air.

    Through the second battery on. Flew it for 10 minutes. battery hit 52% and then it started honking at me, dropped to 7% in 2 seconds and tried to land itself. Luckily it was near me and landed without incident.

    third battery did the exact same thing as the 1st. Put it on, showed 95%, as soon as I tried to accelerate, dropped to under 10% and tried to land.

    I guarantee this is a firmware or app issue. All 4 of these batteries are in good shape. I just came back from San Diego and had flown for hours and hours without incident.

    I'm putting a fresh charge into all 4 batteries and trying again. I think I'll take Dom's suggestion in deleting the apps from my devices and re-downloading them from the DJI site.

    btw....here's the video from Sunset Cliffs I shot last week. ;-) https://www.youtube.com/watch?v=HrR1wN3wOsE
     
  19. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,096
    Likes Received:
    5,623
    Location:
    US
    Elginet, did you also update the firmware on each battery?
     
  20. RichWest

    Joined:
    Nov 1, 2014
    Messages:
    405
    Likes Received:
    43
    Location:
    Houston, Texas
    Take a deep breath....I'm frustrated with my current DJI issues as well. Does the battery indicator on the face indicate full charge or representative of the amount you consumed?

    San Diego and Illinois are a little different temp wise this time of year, I'll presume. Last week worked - warm, this week no - cold. I think you need to look at the data pins once again. They could get stuck due to contraction from colder surrounding parts along with grime/grease and other temp sensitive issues.

    A plastic safe solvent would be ideal to clean the data pin's plunger body. It's worth the time to confirm... Otherwise you may want to consider changing out this effected part. BTW, are these the square data pins or round? IIRC, there were issues in the past with the square version...

    Nice video btw....