Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Yaw arm/ gimbal will not return to center postion

Discussion in 'Phantom 3 Help' started by fletchermcginty, Sep 28, 2016.

  1. fletchermcginty

    Joined:
    Jul 20, 2016
    Messages:
    19
    Likes Received:
    1
    I crashed my p3p and broke the yaw arm, so I replaced the yaw arm. I followed a step by step youtube video on replacing it. After i got the camera and gimbal back on the drone and powered it up i noticed the camera is always looking to the side. I tried an IMU calibration and a gimbal calibration and still nothing. I don't know if i messed something up when putting it back together or what. Here is a video excuse the poor quality but hopefully this explains it better! Thanks in advance
     

    Attached Files:

  2. fletchermcginty

    Joined:
    Jul 20, 2016
    Messages:
    19
    Likes Received:
    1
  3. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    I have seen that happen . Check the yaw motor as the shafts may be bent.

    Sent from my SM-T230NU using PhantomPilots mobile app
     
  4. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    Very hard to see the bend so look closely . It doesn't take much

    Sent from my SM-T230NU using PhantomPilots mobile app
     
  5. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    If it is bent be careful where you get a new one. It has to have the magnet on it. Most new yaw motors don't have the magnet. It is very hard to remove the old one and if you do it has to be put back on exactly the same . See if you can find a good used one.

    Sent from my SM-T230NU using PhantomPilots mobile app
     
  6. fletchermcginty

    Joined:
    Jul 20, 2016
    Messages:
    19
    Likes Received:
    1
    Thank you for the reply! I have noticed when I clip the gimbal base cover on to the circuit bored that is when it gets pulled to the left if I pop that off it spins freely and there is no issue. But as soon as i clip the cover on and tighten the 4 screws that is when it gets held over to the left
     
  7. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    Yes it is bent then. Other than that, does everything else work on it? Video etc? It must have hit hard. Try "hunch" on here to get a replacement with a magnet. FStop sells them too. I put up a post showing how to get the magnet off
     
  8. fletchermcginty

    Joined:
    Jul 20, 2016
    Messages:
    19
    Likes Received:
    1
    yea everything else works great! And yea it took a good hit.... broke the yaw arm, and base cover. Where did you post the video getting the magnet off?
    Thanks for your help Ted!
     
  9. fletchermcginty

    Joined:
    Jul 20, 2016
    Messages:
    19
    Likes Received:
    1
    pardon the horrible video quality
     
  10. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    It was on here but not a video just instructions. You are better off finding one with the magnet. If you get it on wrong it will swing to the left or right. Contact hunch who is on here
     
  11. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    If you can't find one let me know. I will find it for you. Just be sure it has a magnet. I am on vacation but I am sure I have one. I will be back on Oct 12th.
     
  12. HowSR

    Joined:
    Dec 27, 2016
    Messages:
    9
    Likes Received:
    0
    OP,
    how did you resolve the issue?
     
  13. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    finding a yaw motor or swinging to left or right?
     
  14. HowSR

    Joined:
    Dec 27, 2016
    Messages:
    9
    Likes Received:
    0
    Replaced the yaw-motor, and now gimbal only moves between center and far left. As you pointed out, the magnet might be screwed up or missing.
    Any procedures or Pictures which might point me into the right direction on how to align the magnets?

    Thanks
     
  15. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    Can you send a photo of the yaw motor with the magnet?
     
  16. HowSR

    Joined:
    Dec 27, 2016
    Messages:
    9
    Likes Received:
    0
    Can you pinpoint me to the magnet? I am not exactly sure what I am looking for :)
     
  17. HowSR

    Joined:
    Dec 27, 2016
    Messages:
    9
    Likes Received:
    0
  18. HowSR

    Joined:
    Dec 27, 2016
    Messages:
    9
    Likes Received:
    0
  19. Ted4797

    Joined:
    Nov 23, 2015
    Messages:
    1,256
    Likes Received:
    221
    Location:
    Florida
    are you all set?
     
  20. HowSR

    Joined:
    Dec 27, 2016
    Messages:
    9
    Likes Received:
    0
    Not yet. Going to check today

    Casted from my throne using Tapatalk
     
Loading...
Similar Threads - Yaw arm gimbal Forum Date
Standard After yaw arm replacement, DJI app says gimbal disconnected Phantom 3 Help Mar 13, 2017
Gimbal Yaw Arm P4 for P4P? Phantom 4 Pro Discussion Feb 22, 2017
gimbal roll error and yaw arm error Phantom 4 Help Jan 23, 2017
Yaw arm broke, repaired and now gimbal goes crazy, have tried common fixes Standard/4k Discussion Sep 20, 2016
Wanted: P3A Yaw arm for gimbal Classifieds Jul 15, 2016