Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 Firmware Wont Install

Discussion in 'Firmware' started by Rezo, Aug 30, 2016.

  1. Rezo

    Joined:
    Aug 30, 2016
    Messages:
    26
    Likes Received:
    0
    I keep get an error on installing the new Firmware

    ========== 2014.01.01 00:00:12 remo-con disconnect======
    Packet: P3X_FW_V01.09.0060.bin
    Upgrading ...
    Result: Failed.
    Reboot the aircraft and try to upgrade the firmware again.

    Any Ideas?
     
  2. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Make sure you downloaded the right firmware. Also you have a better chance of a successful upgrade if you first format the SD card (make sure you get all your photos and videos off first, format and add the .bin file back to the card).
     
  3. Rezo

    Joined:
    Aug 30, 2016
    Messages:
    26
    Likes Received:
    0
    I just formated it to try again.

    It is the latest software from DJI Site: Phantom 3 Professional Firmware v1.9.60
    2016-06-13

    It seems to start, then the the light goes red and it sits there and makes a reading noise, but never finishes (20 + minutes) .
     
  4. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Is your remote controller off during the upgrade?
     
  5. Rezo

    Joined:
    Aug 30, 2016
    Messages:
    26
    Likes Received:
    0
    Yes.

    I watched a video on how to upgrade and follwed the directions to a "T".
     
  6. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Does it do the fast beeping indicating it is upgrading DDDD-DDDD? If so, does it ever finish making beeps D-DD, D-DD?
     
  7. Rezo

    Joined:
    Aug 30, 2016
    Messages:
    26
    Likes Received:
    0
    It never makes it to the beeps. You se the light go from Green to Red...some flashes....and eventually the light is solid red...and it just sits there reading.

    I just tested a flight...and the card reader is working (Records pictures).
     
  8. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    Thats a strange one. Is the gimbal lock (clear plastic piece) off the camera? You can also try a different SD card, re-download the file in case it's corrupt.
     
  9. Rezo

    Joined:
    Aug 30, 2016
    Messages:
    26
    Likes Received:
    0
    Gimbel lock is off.

    Downloaded 2 difefrent versions of upgrades, both failed.

    Have used 2 different SD Cards.

    Is there anothee method...cable......etc. to upgrade?
     
  10. ryantrax

    Joined:
    Jul 14, 2015
    Messages:
    795
    Likes Received:
    179
    Location:
    Xenia, Ohio
    What is your current version? No I haven't heard of any other way to update it.
     
  11. Rezo

    Joined:
    Aug 30, 2016
    Messages:
    26
    Likes Received:
    0
    Amazingly, the 5th or 6th try it seems to work !

    I am on 1.8.80 so no big deal....but my batteries say they need an update.

    It is workin on install now....just waiting on Long DAAAAAA...Da DA sound to complete.

    It worked on 1 battery , but fails on the other battery, so I am no suspecting a battery issue with the 2nd battery.

    1 battery shows fine in the DJI Go App, but the other gives error messages "Invalid Battery".

    I assume te bad battery is the cause of the fiormware issue
     
  12. AndyK

    Joined:
    Jun 28, 2015
    Messages:
    27
    Likes Received:
    5
    Hi, Ive had exactly the same issues. !! Ive had my p3a for well over a year and have always updated with ease. This latest update is bugging the hell out of me. I download the update to my card(formatted by the go app) plug it into the p3a and all i get on switch on is "dee de de" followed by a solid green light on my gimbal.
     
  13. Rezo

    Joined:
    Aug 30, 2016
    Messages:
    26
    Likes Received:
    0
    My Problem turned out to be a defective battery.

    After several attempts, when I plugged it in and connected with DJI GO App, it showed a battery issue.

    Hopefully this helps