Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Wifi module on Phantom 2 V+ 3.0. Electronic design fault

Discussion in 'Phantom 2 Vision + Discussion' started by Dome, May 3, 2015.

  1. Dome

    Joined:
    Apr 24, 2015
    Messages:
    480
    Likes Received:
    96
    Location:
    Italy
    I'm new to DJI drones, but I'm experienced electronics engineer and model piloting.
    I've bought a Phantom 3 Pro and Phantom 2 Vision+ (for my son), and I received the P2V+ (3.0) 2 days ago from DJI. P3 is still far from here... probably will arrive around the end of may.
    Unboxed and done all the required stuff to let it fly, I faced immediately an interesting issue. The Wifi connections from Phantom drops as soon as I start engines. OMG ... what's that!!. Recheck all the things, RE, Remote Controller and Phantom itself everything is fine. No way as soon I start engines the connection with phone drops (iphone 6+ and OnePlus same behaviour).
    For making a long story short, that's what happen:
    - If I start engines and I've more than 6 GPS sats locked ("Ready-to-fly(GPS)") the connection drop miserably. All the flight controls works normally, camera records on microSD. That's happen all the time.
    - If I start engines and NO GPS lock ("Ready-to-fly(no-GPS)") the connection doesn't drop. I verified this in the lab where no GPS can be recvd. But I haven't dared Phantom in Att mode flight, so I don't know exactly if it would keep connection in flight.

    I've read lot of people with problem like this or similar. I tried suggested solutions, but nothing has changed. I've also checked all firmware, all calibrations. No way.
    But I can easly assert that this problem is related:
    1. Wifi module has serious voltage drop when esc motors starts and shutdown itself (V goes lower the module raccomanded specifications)
    2. ESC Motors induce high level of EMI (electromagnetic interference) to the Wifi module making it crash.

    I don't think it's a heat problem, nor a Range Extender problem, nor a phone problem.
    I'm now investigating about power drops tearing down the phantom... hope to find an answer.
    If anybod can help with more hints ...
     
  2. robsquad

    Joined:
    Dec 4, 2014
    Messages:
    962
    Likes Received:
    422
    Location:
    Wolverhampton, UK
  3. Dome

    Joined:
    Apr 24, 2015
    Messages:
    480
    Likes Received:
    96
    Location:
    Italy
    @robsquad thank you for pointing me to the thread.
    But my problem is different and not related to heat. May be I've fault wifi unit on the brand new P2V+. Oveheating is a problem for sure but on mine it seems to have quite better heat sinking.
     
  4. mohan

    Joined:
    Jan 3, 2015
    Messages:
    527
    Likes Received:
    206
    I think your unit may have a fault - mine does not do this.. I have flown 8000 feet with the wifi and boosted antennas. Pretty amazing for wifi signal to travel this far eh?
     
  5. Dome

    Joined:
    Apr 24, 2015
    Messages:
    480
    Likes Received:
    96
    Location:
    Italy
    @mohan, I hope that's only my unlucky unit .. otherwise DJI would close in a while ...!!

    What let me astonished, is the fact that wifi, BEFORE esc motors start, run fine also at 50-60mt distance, with video at 640x480x30fps on the phone. When I shutdown the esc motors everything is fine again.
    So the problem is something not good in the power supply circuit on the main board ...
    I'm reverse engineering the stuff, I would like to understand...

    In the meantime, I'll ask a replacement to DJI ...:confused::mad: