Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Upgraded to H4-3D, Software Still Says H3-3D

Discussion in 'Zenmuse H3-3D/H4-3D GoPro Gimbal' started by JLou04, Nov 16, 2015.

  1. JLou04

    Joined:
    Oct 5, 2015
    Messages:
    13
    Likes Received:
    0
    Hi Everyone - so over the summer I had a pretty epic crash on my P2 with GoPro. In addition to jacking the shell pretty good, it also bent the H3-3D in a few places.

    After taking it to the drone hospital and getting the shell replaced and the gimbal fixed (as a newbie, I wasn't comfortable doing this myself), it still wasn't performing very well. On most videos the horizon wasn't flat, I was getting pretty bad "jelly", and my FPV video feed was getting a lot of interference when the gimbal would tilt or pan close to the limits.

    So figured if I had to replace it, I might as well upgrade to the H4-3D. Installation was just fine, however, when I go to check the firmware in the Assistant Software, it's still coming up as H3-3D IMU and firmware version 1.0.0.1. But, according to the DJI release notes, the H4-3D should be IMU firmware version 1.13.

    Being that I have a Phantom 2, I don't have the separate GCU to apply updates via the Zenmuse Assistant software..

    So, the question is - is anyone else having an issue with the Assistant Software not recognizing an H4 as an H4. If so, has anyone found any solutions? I've done an awful lot of Googling and forum searching today and haven't found much.

    Thanks!
     
  2. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Does the H4 work as is? What Phantom Assist software do you have?

    If you are **** and want the correct firmware, you may need download previous Phantom Assist version and go through each one to detect the firmware updates. The Phantom Assist software determines the updates.
    If that all fails, you can always do the tweezer firmware reset. This will make the gimbal firmware 0.0.0.0 and it will then prompt you to download a new firmware.
     
  3. JLou04

    Joined:
    Oct 5, 2015
    Messages:
    13
    Likes Received:
    0
    I'm running the latest Assistant software (3.8).

    The H4 seems to work fine in an indoor testing, after installing it (just powering on the P2, not actually flying it). It's responding to the tilt wheel on the RC and seems nice and stable when I move the copter around.

    I could just not look a gift horse in the mouth and leave it alone as long as it's working, It just strikes me as strange that the software doesn't recognize it as an H4 instead of an H3
     
  4. Mako79

    Joined:
    May 16, 2014
    Messages:
    3,418
    Likes Received:
    568
    Location:
    Sydney Australia
    Do an IMU and take it out for a test flight.

    The assist software carries the firmware updates. Sometimes you have to downgrade the P2 assist to detect the correct firmware.
     
  5. JLou04

    Joined:
    Oct 5, 2015
    Messages:
    13
    Likes Received:
    0
    I'll give that a shot. Thanks!
     
  6. jason

    Joined:
    Oct 12, 2014
    Messages:
    4,113
    Likes Received:
    405
    Location:
    Commerce Twp,MI
    If your using the latest v3.8 software and the gimbal is still H3-3D v1.0.0 1 and is working perfectly I'd leave it alone. The latest software for the H3-3D is 1.0.0.12.

    If you receive a message to login when connecting the P2 to the assistant software you'll never know if there is an update for the gimbal until you're logged in.