Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Upgrade required but cant find any F/W updates?

Discussion in 'Pro/Adv Discussion' started by ukglyn, Mar 14, 2016.

  1. ukglyn

    Joined:
    Feb 27, 2015
    Messages:
    396
    Likes Received:
    191
    Location:
    Staffordshire U.K
    Hi all
    I went out flying on Friday which was all good, however my dji app was telling me that an update was required. When I flew it about a week before everything was up to date. I have looked on the DJI site & the latest firmware versions are what i'm running.

    Confusing? Anyone else had this?
     
  2. rockydog

    Joined:
    May 25, 2015
    Messages:
    879
    Likes Received:
    248
    Location:
    London UK
    As far as I'm aware, the only recent update is the GO app to 2.7.0 to include the P4. I flew yesterday, and didn't have any notifications.
     
    BigAl07 and ukglyn like this.
  3. ukglyn

    Joined:
    Feb 27, 2015
    Messages:
    396
    Likes Received:
    191
    Location:
    Staffordshire U.K
    Oh good point, I bet that is what is was wanting me to update. I won't bother then, thanks for that.