Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Unusual situation

Discussion in 'Phantom 2 Vision + Discussion' started by clam, Jun 1, 2014.

  1. clam

    Joined:
    Apr 19, 2014
    Messages:
    10
    Likes Received:
    3
    I have a Phantom 2 Vision+ that has been performing flawlessly for me. I'm running the DJI app on an iPhone 4S.

    When I started flying today I started getting the "control signal lost" indication repeatedly at a very short range. HOWEVAH, control was not lost. I could still control the bird and even when the lost control indication stayed on for several seconds the RTH procedure was not initiated. All batteries in the system were fully charged.

    Anyone have any ideas what could cause this?

    Carroll Lam
     
  2. nintendrone64

    Joined:
    Feb 19, 2014
    Messages:
    353
    Likes Received:
    2
    Location:
    Simi Valley, CA

    Are you running the latest firmware: 3.04?
    That would do it, possibly.
     
  3. RedRyderMedia

    Joined:
    Apr 7, 2014
    Messages:
    750
    Likes Received:
    31
    Check the orientation of your antenna.
     
  4. Flyer91

    Joined:
    Apr 16, 2014
    Messages:
    360
    Likes Received:
    51
    Location:
    In the Sierras, 17 miles outside Yosemite N. P.
    Where you flying in a different place, possibly near transmissions antennas?
    Has it repeated the same behavior, and at some other location?

    If not, then it may just have been interference of some sort, and/or a simple glitch.
    Hopefully it was just something like that.
     
  5. AHill

    Joined:
    Oct 10, 2013
    Messages:
    227
    Likes Received:
    23
    Anything blocking a direct line of sight between transmitter and Phantom could interfere with signal. I have had this happen when flying on the other side of an aluminum light pole.