Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Ultrasonic System Error - Land Immediatley

Discussion in 'Pro/Adv Discussion' started by Mike Slater, Jul 17, 2016.

  1. Mike Slater

    Joined:
    Nov 21, 2015
    Messages:
    40
    Likes Received:
    5
    Took a new P3P out for its first flight out of the box. About 9 minutes out I got that Ultrasonic System Error thing. Brought it back with no issues. I had thought it said battery was critical land immediately but check the log and that was what the error read. Have the 1.9 version as well. See what happens. I may just disable the VPS as other threads say. More Fun!!
     
  2. Reed L

    Joined:
    Sep 13, 2015
    Messages:
    1,265
    Likes Received:
    390
    Location:
    Alta, Ca.
    It is the VPS but if you have a camera guard, some of the off brands stick back to much and may help cause this problem. Disable VPS and that will put a bandaid on it, but check for other problems either way.
     
    Digdat0 likes this.
  3. Mike Slater

    Joined:
    Nov 21, 2015
    Messages:
    40
    Likes Received:
    5
    Thanks! No camera guard. According to the folks I bought it from it is a common problem with P3P. Will go through the voodoo again and see what happens.
     
  4. Mike Slater

    Joined:
    Nov 21, 2015
    Messages:
    40
    Likes Received:
    5
    I was talking to a friend of mine who had the same issue while in California. He wasn't sure if this caused it but when he calibrated his compass he was getting compass errors. Tried twice but had the same compass error. He flew anyway and it cleared up. He too got the Ultrasonic Error. While he was packing up he noticed that he had calibrated over a large underground metal pipe. Don't know if the two are related.
     
  5. Vertigo

    Joined:
    Jun 12, 2016
    Messages:
    499
    Likes Received:
    148
    They are not. Ultrasound sensor and compass have nothing to do with each other. Check if the ultrasound sensors are clean, there might be some dirt in them. Try blowing them out gently with compressed air.