Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Trouble with Phantom 2 and hub for video.

Discussion in 'General Discussion' started by brivander, Apr 23, 2016.

  1. brivander

    Joined:
    Jan 27, 2016
    Messages:
    42
    Likes Received:
    2
    Location:
    Brownstown, MI
    So, all of a sudden my picture on my black pearl got VERY dim. I messed with all of the connections with no luck. I happened to switch the DJI hub from OSD to VID and the picture is perfect (obviously losing my telemetry). I did happen to have an extra hub around and tried it with the same results.
    Anyone know what can cause this? All of my playing around and I can not seem to figure anything out. It's been working perfect out to over 1km for a few months until yesterday. Possibly a bad iosd mini???

    AVL58 with hub kit, cloverleaf antenna, H3-3D, DJI iosd, and black Pearl monitor/receiver.
     
Loading...
Similar Threads - Trouble Phantom hub Forum Date
Have trouble installing drivers on my windows 8.1 with DJI Phantom 2 Vision Assistant_3.8 Phantom 2 Vision + Help Sep 24, 2016
Trouble with motor on Phantom vision plus Phantom 2 Vision Discussion Sep 20, 2016
My Phantom 2 vision + won't connect to my laptop. I am having trouble with starting the motors. Phantom 2 Vision + Help Sep 18, 2016
Professional Need help troubleshooting my gimbal on a Phantom 3 Professional Phantom 3 Help Apr 14, 2016
Trouble with connecting the remote to the phantom 2 Phantom 2 Vision Discussion Mar 16, 2015