Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Derek Mackinnon

    Joined:
    Apr 7, 2016
    Messages:
    88
    Likes Received:
    48
    Location:
    Aberdeen, Scotland
    Flying the phantom 4 tonight in sports mode and switched to GPS and the camera stopped working from the controller.

    It's staying level but swinging from left to right when you spin the drone. There is still friction against it. It's not totally loose but shouldn't be swinging.

    I'm also getting video transmission warnings and the camera on the I pad display is turning on and off.

    Any experience with this issue? is it worth checking for a loose ribbon cable or just sending in for repair?

    Thanks

    Derek

    Sent from my SM-G935F using PhantomPilots mobile app
     
  2. Melvin murphy

    Joined:
    Jul 28, 2016
    Messages:
    3
    Likes Received:
    1
    Same issues after a light crash , I did a cold imu and a Gimble calibration which corrected I would estimate 70 percent of the problem but still to much side to side movement to make flying enjoyable. So far I haven't gotten any help on this problem. I have a call in to a repair center if I get any info I will share it with you.
     
    Derek Mackinnon likes this.
  3. Derek Mackinnon

    Joined:
    Apr 7, 2016
    Messages:
    88
    Likes Received:
    48
    Location:
    Aberdeen, Scotland
    Thanks for that Melvin. I think I'll send mine in for repair and see what they say.

    Sent from my SM-G935F using PhantomPilots mobile app
     
  4. Derek Mackinnon

    Joined:
    Apr 7, 2016
    Messages:
    88
    Likes Received:
    48
    Location:
    Aberdeen, Scotland
    I'll share my information on this issue that is now fixed

    I decided to throw caution to the wind and remove the camera. This was easy enough and is held in with some small Allen screws and 2 cables and

    One cable requires you to remove a small.metal shield that holds down the ribbon cable and the other is just a plug. Removed both had a look then replaced them.

    The camera and drone is now fully functional again. It must have been a loose cable.

    Happy I didn't have to ship it for repair.