Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

  1. Big Eoin

    Joined:
    Apr 13, 2016
    Messages:
    25
    Likes Received:
    1
    Hi folks, I need some help please.

    I recently updated my my controller to take a UAV Maxx antenna but I have not flown the bird for about two months.

    I have just switched on my bird and controller and Go App. App is asking me to connect my device but the bird is showing flashing green at the back and solid Red at the front.

    The manual shows this as a critical error. I have done no work on the bird so I don't understand the cause.

    Any help would be appreciated.


    Sent from my iPhone using PhantomPilots
     
  2. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    4,041
    Likes Received:
    1,181
    Location:
    Brookeville, MD, USA
    Did you start the motors? Have you looked at your manual? Flashing green in the back and solid red in the front (with motors spinning) means it's ready to fly on my P2V. Be sure your switches are up and sticks are centered. The P4 might be different.

    Sounds like there's a problem with your FPV.
     
  3. Erised

    Joined:
    Apr 2, 2016
    Messages:
    824
    Likes Received:
    340
    Same for the P4, solid red front flashing green rear, when your rear green lights start to flash red thats your low battery warning , solid red in the rear is a critical warning(10% bat is a critical warning also). If your RC left light is green you are connected, if red you are not.
     
  4. IIIDaemon

    Joined:
    Jul 31, 2016
    Messages:
    95
    Likes Received:
    6
    Location:
    0.591088°, -90.750456°
    .
    upload_2016-10-9_0-57-56.png
    .
    ...My P4 also has Solid Red Front Lights and Flashing Grn Rear Lights... when this SWT is in the ON position...
    .
    IIIDaemon
    www.GasRecovery.net
     
  5. TheLightSpeedz

    Joined:
    Jan 24, 2016
    Messages:
    1,187
    Likes Received:
    366
    Wait solid red front and flashing green in the back is the "all good" sign? Yes?


    Sent from my iPhone using PhantomPilots
     
  6. Mark The Droner

    Joined:
    Aug 26, 2015
    Messages:
    4,041
    Likes Received:
    1,181
    Location:
    Brookeville, MD, USA
    I'm sorry, but I think some of the pilots need to spend some time reading the owner's manual for their aircraft. The entire manual really needs to be carefully studied from top to bottom at least twice in my opinion. There should be no question in their minds what the lights on their AC are telling them.

    For example (and this is to my P2V in Naza mode, not a P4).

    Rear lights flashing alternate colors: Boot up

    Front lights off: Props are either not spinning or are spinning in idle

    Front lights red: Props are spinning and are spinning faster than idle

    Rear lights flashing green 2x rapidly: Sticks on controller not centered

    Rear lights flashing green 20x (1st time since boot): AC compass is working and AC knows where it's pointing relative to magnetic north

    Rear lights flashing red 3x and green 1x: AC has acquired 4 satellites or less

    Rear lights flashing red 2x and green 1x: AC has 5 satellites

    Rear lights flashing red 1x and green 1x: AC has 6 satellites

    Rear lights flashing green 2x: AC has 7 satellites or more:

    (replace green with yellow above indicates ATTI mode instead of GPS mode)

    Rear lights flashing green 20x (2nd time since boot): Home point is marked

    Rear lights are flashing red slowly: Battery is low, you must land now

    Rear lights are flashing red fast: AC is in auto-land

    Do some of these apply to the P4? If you're not sure, please read your manual. You shouldn't have to rely on your app for everything.
     
  7. N017RW

    Joined:
    May 2, 2014
    Messages:
    6,257
    Likes Received:
    1,618
    Location:
    Palm Beach Co.- FL
    Had similar issue a few weeks back.

    Clean battery data terminals.
    No need for abrasives.

    Alcohol and a q-tip or paper towel.

    There may be several causes for the error but this was mine.