Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

RC led is yellow

Discussion in 'Phantom 2 Discussion' started by rockhoundrob, Mar 15, 2015.

  1. rockhoundrob

    Joined:
    Dec 23, 2014
    Messages:
    151
    Likes Received:
    8
    Location:
    Oklahoma City, Oklahoma, USA
    I was double checking everything, and noticed that when I turned on my RC, the battery power was full, but the "Power on" led was yellow.

    What does this mean? I did recalibrate it and now it is green. But why was it yellow before?
     
  2. rockhoundrob

    Joined:
    Dec 23, 2014
    Messages:
    151
    Likes Received:
    8
    Location:
    Oklahoma City, Oklahoma, USA
    FINALLY found out why it was yellow!

    When you do a TX calibration, you need to close the assistant window on the screen BEFORE you turn off the TX or unplug the USB cord.

    I assume its the same when calibrating the Phantom. Close the assistant screen BEFORE turning off the Phantom or removing the USB cord.
     
  3. frankm

    Joined:
    Mar 21, 2015
    Messages:
    1
    Likes Received:
    0
    My RC power light is now yellow and will not start motors. I tried recalibrating both ways several times no solution. Anyone else have any tips? It all started when I was messing around with the settings
     
  4. rockhoundrob

    Joined:
    Dec 23, 2014
    Messages:
    151
    Likes Received:
    8
    Location:
    Oklahoma City, Oklahoma, USA
    I suggest the following steps. (let us know what kind of phantom you have. it will help if we know what you have).

    1) Make sure all batteries are maxed (or at least 75%)

    2) Calibrate the remote control first.
    a) Turn on remote control and plug into PC using USB
    b) Open RC assistant and do calibration (be sure to click start and then NEXT). after you have moved all levers around, then click finish.
    c) I think you have to do a 2nd calibration for the S1 and S1 switches, do those too.
    d) when you are done, click the X at the top of the window to close the RC assistant Window.
    e) turn off remote controller.

    3) Plug Phantom 2 in USB on PC and turn on (make sure the propellers are removed first).
    a) turn on remote controller (this is not connected to PC)
    b) open Assistant to calibrate phantom ( not the RC assistant) If you have a Phantom 2, then open the assistant that is ver 3.6.
    c) follow steps to calibrate phantom in Basic first. This is where you should be able to see the arrows move from side to side when you move the sticks.
    this part makes sure the phantom is getting the signal from the controller.
    d) do the next things like IMU...Basic cal, not the Advanced cal and make sure the phantom is level and dont move it while calibrating. this should only take about 15 seconds.
    e) close assisant window, unplug USB, then turn off phantom.

    4) for test, just take the phantom in your backyard and do compass calibration. then wait for GPS to link up. if that is successful, then try starting motors ( without the propellers).
    If it works, then you got it. If not, then let us know and I will try to find a link for you to look at, but we need to know what kind of Phantom you have.
     
  5. Marlin009

    Joined:
    Dec 31, 2014
    Messages:
    1,091
    Likes Received:
    515
    Location:
    West Coast of Florida
    In your step 3, always turn on remote before phantom. ;)

    Also, I'm not sure why folks try to calibrate the compass before the Phantom has initialized and is ready to fly.
    It eliminates any confusion as to whether the calibration was successful.
     
  6. rockhoundrob

    Joined:
    Dec 23, 2014
    Messages:
    151
    Likes Received:
    8
    Location:
    Oklahoma City, Oklahoma, USA