Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Rapid flashing yellow lights

Discussion in 'Phantom 2 Vision Discussion' started by smatty2023, Mar 27, 2014.

  1. smatty2023

    Joined:
    Jan 22, 2014
    Messages:
    112
    Likes Received:
    0
    I have carried out a mod on the uav for the extended aerials all check and working re the connections..when I power up I get the rapid flashing yellow lights. I reset the phantom to bind the controller and the little light goes out indicting a positive bind when the controller is on but still have rapid flashing amber lights.
    Any suggestions gratefully received
     
  2. amkorp

    Joined:
    Mar 14, 2014
    Messages:
    127
    Likes Received:
    2
    Location:
    Toronto, Canada
    Did you do the mod on the transmitter/extender side or on the drone/camera side?

    What exactly was the mod that you did?
     
  3. smatty2023

    Joined:
    Jan 22, 2014
    Messages:
    112
    Likes Received:
    0
    Hi I have done both ends I did the land side first with no problems. I then completed the uav end a tech guy I know the the solder joints uav end tested absolutely fine. I have put the uav back together and get the rapid yellow flashing lights. I had a spade brand new receiver so I swapped them out but does exactly the same. I go through binding procedure on both receivers and it does what is expected ie press tiny reset button with uav on the light flashes amber as soon as you turn the controller on it detects it then the tiny light on the phantom goes out indicating a positive bind but still rapid flashing yellow lights. I'm in nazam mode
     
  4. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    Do you see any control inputs at all when you run the Assistant? In the updates section is the receiver showing as installed and with valid firmware? See if it shows 0.0.0.0...

    Otherwise is there a chance that there was damage done to the connectors/cables from receiver to main board when you did the mods?
     
  5. smatty2023

    Joined:
    Jan 22, 2014
    Messages:
    112
    Likes Received:
    0
    All sorted I think, I took the controller apart to plug it in via USB to the computer ran the software to see if it was calibrated ok, and it indicated a software update did this then had to recallibrate the controller powered up the UAV and bingo paired straight away. I thought all the software updates were at the UAV end?, either that or my hand controller has needed an update ever since I had it.
     
  6. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    It's the latter... :)
     
  7. smatty2023

    Joined:
    Jan 22, 2014
    Messages:
    112
    Likes Received:
    0
    Ok obviously the new update made the difference in firmware too far apart. I'm just glad I have sorted it I had visions of sending it back and being without it for weeks. Thanks for your help.
     
  8. Pull_Up

    Joined:
    Nov 5, 2013
    Messages:
    3,684
    Likes Received:
    48
    Location:
    South Oxfordshire, UK
    No prob. Glad it was an easy fix in the end.