Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Purple lines in Videos & Pictures when using my P3P

Discussion in 'Pro/Adv Discussion' started by Speedy-UK, Feb 21, 2016.

  1. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    Not all the time but sometimes my P3P recodings have about 10 - 20 purple lines running down the screen,
    I also see this on my hudl 2 tablet & Phone 6S live feed as well as when watching back via the SD in my laptop.

    Am thinking its a faulty camera ribbon issue.
    Am I best changing the ribbon? is this an easy task ?
     
  2. DroneDestination

    Joined:
    Jan 15, 2016
    Messages:
    698
    Likes Received:
    126
    Do you have Over Exposure Warning on?
     
  3. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    Is that the setting that puts black bars over exposed areas.
    If so yes this is off.
     
    #3 Speedy-UK, Feb 21, 2016
    Last edited: Feb 21, 2016
  4. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    Yes -- the zebra stripes.

    Try using a different memory card. If you see the same issue at that point, then the cables are most likely the cause of the problem. They might just be loose.
     
  5. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    I have 3 x 32gb SD cards, 80mbps Speed.

    Had same issue on all of them.

    I will try pushing in ribbon connections.

    Thanks.


    Sent from my iPhone using PhantomPilots mobile app
     
  6. Oso

    Oso

    Joined:
    May 19, 2015
    Messages:
    2,544
    Likes Received:
    1,490
    Location:
    Sacramento CA
    Since you said you still see the issues when viewing the videos from your SD card, the over exposure zebra stripes are not the issue. Not to mention "10-20 purple lines running down the screen" doesn't sound like the zebra stripes anyway.

    I would also think cables first and I would first try unplugging them and plugging them back in before looking anywhere else.

    Please keep us updated. Good luck!
     
  7. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    Will give this ago tomorrow. Thank you.


    Sent from my iPhone using PhantomPilots mobile app
     
  8. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    I reconnected the ribbon ends and still got the issue.
    I have now noticed the lines seems to only show when the camera is pointing towards the sun.

    So today Installed a ND 16 filter and when out flying & I did not get any issues with the purple lines.
    (40 minutes flying)

    Am now thinking I only get the issue when the ISO is very high.

    Anyone have a clue why ?


    Sent from my iPhone using PhantomPilots mobile app
     
  9. With The Birds

    Joined:
    Jan 4, 2016
    Messages:
    2,622
    Likes Received:
    751
    Location:
    Australia
    In my case it was a faulty canera, replaced under warranty (P3P).

    The lines apprared as acattered random purple however when i zoomed in it was obvious that while parts of the image.had been shifted elsewhere in the image.
     
  10. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    Could my camera be faulty ?


    Sent from my iPhone using PhantomPilots mobile app
     
  11. With The Birds

    Joined:
    Jan 4, 2016
    Messages:
    2,622
    Likes Received:
    751
    Location:
    Australia
    Could be. Writing images with what sounds like simillar problems to what i had on multiple sd cards. In my case it was a faulty camera.
     
  12. Tim_alabim

    Joined:
    Nov 1, 2015
    Messages:
    60
    Likes Received:
    31
    If only when facing the sun, it sounds like prop shadows.
     
  13. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    Prop shadows are always horizontal though. The OP mentioned running "down the screen", so I'm assuming that means these lines are vertical.
     
  14. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    Will add a picture later.
    Not seen since using ND16 filter.


    Sent from my iPhone using PhantomPilots mobile app
     
  15. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    [​IMG]


    Sent from my iPhone using PhantomPilots mobile app
     
  16. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    All OK with ND16 but anything less lines comes back.

    Also seems to be getting worse, as you can see in the picture above.
     
  17. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,117
    Likes Received:
    5,632
    Location:
    US
    Speedy-UK, try a different memory card. If that does not fix it, ensure the gimbal cables are fully inserted.
     
  18. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    I have tried a few SD cards.
    Might need a new ribbon cable.

    An if it's the camera am not sure if I'll be coved by DJI as I got my P3P from a supply on eBay that's no longer trading.


    Sent from my iPhone using PhantomPilots mobile app
     
  19. L.Chaney

    Joined:
    Jun 6, 2015
    Messages:
    180
    Likes Received:
    49
    I fixed mine I hope. I started fiddling around with the firmware and got things to where there were no more lines.
    App version 2.6.0
    Aircraft 1.4.10+
    RC 1.3.20

    Not that it will work for you but I no longer have that purple gorilla on my back.
    Woot
     
  20. Speedy-UK

    Joined:
    Feb 18, 2016
    Messages:
    34
    Likes Received:
    2
    Just thinking did I get the lines after an update.
    But there been a few updates so can't remember.


    Sent from my iPhone using PhantomPilots mobile app