Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Problems with NAZA assistant program

Discussion in 'General Discussion' started by CcrtAgntMn, Jan 16, 2014.

  1. CcrtAgntMn

    Joined:
    Jan 1, 2014
    Messages:
    5
    Likes Received:
    0
    Just bought a gimble and need to activate the gimble function in NAZA. I'm have trouble getting my computer to recognize the USB when hooking up my phantom. I can download the software and install the drivers, but I can't get it to connect. I purchase my phantom from person on Ebay and getting no help from DJI. Anyone have any ideas?
     
  2. rmklaw

    Joined:
    Nov 27, 2013
    Messages:
    300
    Likes Received:
    1
    The sequence is:
    1. download the Assistant software making sure you are downloading the correct version for your Phantom, and open the program;
    2. Plug the Phantom to the computer;
    3. Power up the controller, then the Phantom;
    4. Install the drivers, and when it asks you if the USB is connected, say yes;
    5. Software should recognize your Phantom at this time.
     
  3. CcrtAgntMn

    Joined:
    Jan 1, 2014
    Messages:
    5
    Likes Received:
    0
    Still not working. I get a code 43 on the device nManager, which is a driver error
     
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Check/wiggle the USB cord at the point it plugs in to the LED board inside the Phantom. If that doesn't get the PC to see the NAZA (and load the driver), try a different USB cable.
     
  5. rmklaw

    Joined:
    Nov 27, 2013
    Messages:
    300
    Likes Received:
    1
    Have you loaded the right driver. There are two. One for Win8 and the other for the rest. I would try unplugging and uninstalling the driver, and then reinstalling it. Also, make sure that your firewall and antivirus are disabled for the installation.
     
  6. jmwquad

    Joined:
    Apr 27, 2013
    Messages:
    10
    Likes Received:
    0
    I've had the same problem. My computer doesn't recognize the USB connected device. I installed the upgrade board for the gimble and the phantom powers up and gives me correct lights and motors (without props) seem to work, etc... But I can't get it to connect to do firmware update and initiate gimbal. Before changing the board it connected to PC fine. I've tried wiggling usb cable and using another cable and nothing.