Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Please help me figure out FPV issue

Discussion in 'Phantom 2 Vision + Discussion' started by eyecon82, Nov 10, 2014.

  1. eyecon82

    Joined:
    Oct 18, 2014
    Messages:
    616
    Likes Received:
    67
    So, I have installed stage 2 FPVLR antennas, but my fpv range is horrible, even worse than stock.

    I upgraded to the Tp-link ones originally , and got good range, but as soon as I screwed on the fpvlr, it sucked.

    Although, at the same time we did have this major update, so I don't know what the problem is anymore and I don't have my old Tp-link antennas to test anymore

    Before, I would be able to connect, but always got Phantom connection broken, but rebinding fixed that.

    Then, I would get telemetry and no video and it was a bad SD card issue so replacing SD card fixed that

    Now, nothing will make it work. Rebinding, formatting sd cards, etc.

    I'll get fpv and telemetry up to maybe 300 feet, and after that I lose everything even though range is still awesome and camera will take stills and videos if I'm able to connect and stay within 300 feet of my p2v+

    If I come back within the 300 foot range, I sometimes get fpv and telemetry back, sometimes not. Sometimes only telemetry. It's always random.

    I also have issues staying connected to my phantoms wifi. It gets wifi signal and connects and disconnects over and over. Sometimes I get good connections.

    I also took my wifi card out and it is heat sinked properly and no physical signs of overheating.

    I have a samsung Galaxy S5.

    Please help!
     
  2. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    17
    If you expect to see physical signs of overheating.... well thats not always going to happen. There are components that you may have not examined that are not properly heat sinked. Its obvious that your wifi module is having issues.

    You may be getting outside wifi interference but its likely the module.

    viewtopic.php?f=27&t=28176
     
  3. eyecon82

    Joined:
    Oct 18, 2014
    Messages:
    616
    Likes Received:
    67
    Thanks. When I lose video now, telemetry also goes. It seems for most people, they still have telemetry and no video.

    When I lose video, I also lose full connection
     
  4. burlbark

    Joined:
    Oct 6, 2014
    Messages:
    502
    Likes Received:
    17
    Lets move this to the wifi units are dying thread.... Once your unit starts showing these symptoms it usually to late. But its worth a try anyway.
     
  5. eyecon82

    Joined:
    Oct 18, 2014
    Messages:
    616
    Likes Received:
    67
  6. eyecon82

    Joined:
    Oct 18, 2014
    Messages:
    616
    Likes Received:
    67
    And I'm still having issues after properly heatsinking my wifi card. I get great fpv/telemetry within a 200 foot range it.

    Once I go past it, it disappears and my wife disconnects.

    Once I'm back within the 200 foot range, it works properly again. Any ideas?
     
  7. Wheat

    Joined:
    Apr 21, 2014
    Messages:
    74
    Likes Received:
    8
    Location:
    Kalamazoo, MI
    I noticed that I am having some of the same issues. I believe it may be my phone, the Galaxy S5 as well. Before I used my iphone and had no issues and then I got a new phone and did not put the two together. I had an older Droid Razr and tried that and had great range. I have not gone out to try them both out but I have noticed that my Galaxy phone drops the hotspot connection a lot more. That gave me the idea to switch devices. I have also noticed when I first tried it when I scanned networks I could see some of my neighbors wifi networks with my Droid that I can not see with my S5. This makes me believe that the wifi is not that great with the S5. You might want to try a different device and see if that works better. I was about to get a FPV upgrade before I found this out. I have got 1 mile before with my iphone but I have not tried that same area with my S5 but I don't think I could get that again.
     
  8. eyecon82

    Joined:
    Oct 18, 2014
    Messages:
    616
    Likes Received:
    67
    Yes the Samsung Galaxy wifi sucks, but that wasn't the problem.

    The problem was faulty/damaged antennas.

    Before with the faulty ones, I kept gaining and losing wifi connections. Sometimes multiple times over a span of a few seconds
     
  9. eyecon82

    Joined:
    Oct 18, 2014
    Messages:
    616
    Likes Received:
    67
    So i switched out the faulty antennas for my old Tp-link ones and everything is all good now