Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom won't take off

Discussion in 'Phantom 2 Discussion' started by greytail, Mar 9, 2014.

  1. greytail

    Joined:
    Mar 7, 2014
    Messages:
    40
    Likes Received:
    0
    Location:
    Vermont
    After doing all the updates, my phantom 2 won't fly. Doesn't seem to have sufficient revs to take off. I have two steady green lights in the front and nothing in the back. On one occasion I had two greens in the front and two reds in the back. Is this a stupid mistake or something genuinely wrong with the unit?. Battery was reading good. Since I only got it a couple of days ago, think I will send it back to B&H. I checked today and provided there is no damage, they will take it back up to 30 days. I saved all the packaging.
     
  2. Fdnyfish

    Joined:
    Jun 6, 2013
    Messages:
    664
    Likes Received:
    36
    Location:
    Barnesville, PA
    Recalibrate your sticks
     
  3. Fink

    Joined:
    Feb 25, 2014
    Messages:
    195
    Likes Received:
    0
    Location:
    Orlando, FL
    I wouldn't return it yet, man.

    Go back to the drawing board. Plug the Phantom back in to the P2 Assistant software, get your transmitter powered on and run through everything. Check to be sure the Phantom is getting the correct signals from the transmitter which you can do directly from the P2 Assistant software. If all looks good in the P2 Assistant software, power everything down and get your transmitter hooked up to the RC Assistant software. Run through the calibration several times until everything is in the green.

    If you're mind is set on returning it, use this as your chance to learn. Use the unit you have now to learn everything there is to know about the software and run through some stick, IMU and compass calibrations with it.

    Good luck!

    Fink[​IMG]
     
  4. greytail

    Joined:
    Mar 7, 2014
    Messages:
    40
    Likes Received:
    0
    Location:
    Vermont
    okay will take you advise....there was one thing in the software I didn't understand.....connecting to the X1 port....what is that all about?
     
  5. ianwood

    ianwood Taco Wrangler
    Staff Member

    Joined:
    Jan 7, 2014
    Messages:
    4,910
    Likes Received:
    1,789
    Location:
    Lost Angeles
    Lights in the front are only ever red and that is when the motors are spinning. Green in the back is good. Red in the back is not good. That's a gross oversimplification but let's start there.
     
  6. greytail

    Joined:
    Mar 7, 2014
    Messages:
    40
    Likes Received:
    0
    Location:
    Vermont
    Went through the alignment again today. Hooked up the P2 to the usb and ran the phantom software. Had the controller box nearby an rotated the sticks as per the instructions. Everything is centered on the left side menu, but not sure of what is is supposed to be on the right. What is that little red tick there in the X1 calibration line...shoulthe black arrow be arrow be there?