Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Phantom 3 Pro Stuck on Warming Up

Discussion in 'Phantom 3 Help' started by Mike Slater, Dec 20, 2015.

  1. Mike Slater

    Joined:
    Nov 21, 2015
    Messages:
    40
    Likes Received:
    5
    Took the quad out to show the neighbor. Turned in on and it stayed stuck on Warming Up. Sat there forever too. Camera worked, had gimbal control etc. There was a message that came up that said "Slave requests gimbal controls" That was a new one. Went back home, downgraded and then upgraded again, still the same. RC link light is green. Took it out a couple of days ago after the new upgrade to 1.5, now, not so much. Any thoughts out there?
     
  2. msinger

    Approved Vendor

    Joined:
    Oct 30, 2014
    Messages:
    19,073
    Likes Received:
    5,617
    Location:
    US
    Try reinstalling the DJI GO app.
     
    jryser likes this.
  3. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,376
    Location:
    Live! From New York!
    It is a pleasure to welcome you to the Phantom Pilots forum Mike. I hope that you will take advantage of the benefits that come with membership and that you will be able to use the forum for the exchange of innovative ideas and as a resource for current developments in Phantom quadcopter’s.

    Have you tried to recalibrate the quad?
     
  4. Mike Slater

    Joined:
    Nov 21, 2015
    Messages:
    40
    Likes Received:
    5
    THANKS MSINGER!!! That did the trick. Was there a update to DJI GO app?
     
  5. Mike Slater

    Joined:
    Nov 21, 2015
    Messages:
    40
    Likes Received:
    5
    Thanks LuvMyTJ!!
     
  6. LuvMyTJ

    LuvMyTJ ADMINISTRATOR
    Staff Member

    Joined:
    Feb 9, 2014
    Messages:
    6,811
    Likes Received:
    4,376
    Location:
    Live! From New York!
    There was an update just a day or so ago. Glad to hear you got it up & running.
     
  7. Mordor

    Joined:
    Jul 27, 2015
    Messages:
    639
    Likes Received:
    114
    Also, (someone confirm or not) a bad IMU can cause a long warm time delay...

    Welcome to the forum!
     
  8. bobmyers

    Joined:
    May 10, 2015
    Messages:
    3,611
    Likes Received:
    866
    Location:
    San Antonio, TX
    Maybe not--not sure-- but an IMU not calibrated with the Phantom being cool--- will lead to long warmup time.