Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Professional Phantom 3 feel out of the sky!!!

Discussion in 'Phantom 3 Help' started by Reuben, Jun 14, 2015.

  1. Reuben

    Joined:
    Jun 14, 2015
    Messages:
    53
    Likes Received:
    6
    i was just flying my 1 week old phantom 3 pro and it literally feel out of the sky in front off me. I could hear the motors turned off and the they tried to start again. What on earth just happened? it was about 10 meters in the air! The gimbal looks like its broken and also video feed is gone!
     
    #1 Reuben, Jun 14, 2015
    Last edited: Jun 14, 2015
  2. 30secs

    Joined:
    Jun 12, 2015
    Messages:
    889
    Likes Received:
    113
    Sorry to hear man. Good thing it wasn't far from you. Did you get any warning alerts?
     
  3. Reuben

    Joined:
    Jun 14, 2015
    Messages:
    53
    Likes Received:
    6
    I don't know as I was looking at the drone and not the phone screen! All I can tell is that the motors stopped spinning then when it started falling they tried to spin up again briefly. Will contact DJI in the morning I guess!
     
  4. Reuben

    Joined:
    Jun 14, 2015
    Messages:
    53
    Likes Received:
    6
    Also since the drone was only about 10m from the ground I guess there was not much time to recover.
     
  5. Gurmeet

    Joined:
    Jun 12, 2015
    Messages:
    20
    Likes Received:
    1
    Sorry to hear about your loss.

    Did you managed to speak to DJI?
     
  6. FlipFlap

    Joined:
    May 18, 2015
    Messages:
    37
    Likes Received:
    13
    Can you describe more details. How long were you flying? How much battery was left? Did you have any warning signs like compass error? How many flights did you have and how long have you flown each flight previously
     
  7. bbfpv

    Joined:
    Feb 3, 2015
    Messages:
    3,744
    Likes Received:
    1,092
    Location:
    Long Island, NY
    post the flight log.
     
  8. Panotaker

    Joined:
    Jan 25, 2014
    Messages:
    43
    Likes Received:
    18
    Sounds like a loose battery or bad connection on the battery, but I'm no expert.