Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 vision plus auto landing

Discussion in 'Phantom 2 Vision + Discussion' started by mazo78, Sep 11, 2015.

  1. mazo78

    Joined:
    Oct 28, 2014
    Messages:
    57
    Likes Received:
    0
    i had this problem last Sunday .
    phantom is auto down and i lost throttle up control but other control (left ,right , forward and back ) only i was lost throttle up control ,
    battery was 95%
    satellite was 8
    temperature --3.6C
    height from sea level 4173 M
    ***************Sorry for my bad English ********************
    check this video
     
  2. robsquad

    Joined:
    Dec 4, 2014
    Messages:
    962
    Likes Received:
    422
    Location:
    Wolverhampton, UK
    have you got another battery to try ?
     
  3. mazo78

    Joined:
    Oct 28, 2014
    Messages:
    57
    Likes Received:
    0
    yes i try other battery but same problem
    i have this problem only cold weather
     
  4. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    Are you keeping the batteries warm right up until the time you fly?
     
  5. mazo78

    Joined:
    Oct 28, 2014
    Messages:
    57
    Likes Received:
    0
    yes
     
  6. RichWest

    Joined:
    Nov 1, 2014
    Messages:
    405
    Likes Received:
    43
    Location:
    Houston, Texas
    Since the LiPo battery is effected by cold temps you could try to improve performance by heating up the bird. As a test, try covering all the vent holes around the bird with tape. The lack of air flow through the bird may provide enough system warmth to offset the sub zero temps. Good luck!

    Edit to add: Possibly not practical, placing tape in the opens of the battery may offer another heat retaining insulator.
     
    #6 RichWest, Sep 12, 2015
    Last edited: Sep 12, 2015
  7. robsquad

    Joined:
    Dec 4, 2014
    Messages:
    962
    Likes Received:
    422
    Location:
    Wolverhampton, UK
    what % is RTH set at in the assistant ?
     
  8. Pathfinder

    Joined:
    Jul 25, 2015
    Messages:
    3
    Likes Received:
    0
    I had a similar issue; however, it was at sea level and a fog bank was rolling in. Temperature was around zero. What I found was a thin layer of ice building up on the rotor blades leading/trailing edges. Any chance you are experiencing icing of the blades. Icing would change the profile of the blades and reduce the lift.
     
  9. Pathfinder

    Joined:
    Jul 25, 2015
    Messages:
    3
    Likes Received:
    0
    Any chance the blades are icing up? I've had a similar situation with controls and I was getting ice build up on the edges of the rotor blades. Temperature was slightly above zero in my situation and a fog bank was rolling in.
     
  10. RoyVa

    Joined:
    Apr 10, 2015
    Messages:
    2,246
    Likes Received:
    449
    Location:
    Virginia
    If the issue persist I would try re-calibration of the RC sticks and see if that helps. If it doesn't I would connect to the assistant and watch the stick movement tomseenwhatnit the left stick is doing and showing the correct movements. If they differ you may have a hardware issue with that left stick.