Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

phantom 2 vision motors speed up while setting idle

Discussion in 'Phantom 2 Vision Discussion' started by colshawn, Jun 8, 2014.

  1. colshawn

    Joined:
    Jun 8, 2014
    Messages:
    4
    Likes Received:
    0
    I upgraded the phantom 2 vision to the latest version of assistant software and i noticed that when i fly the copter and land it, if i leave the blades running while on the ground they speed up. I can pull down on the stick and slow them back down (some times) but other times it appears to be non-responsive.

    anyone having similar issues like this. I am not sure the assistant software update had anything to do with this but it is the only thing i have recently changed or modified.

    The copter is responding as it should in the air but the issue with the motors speeding up while on the ground is concerning to me.

    any advice is appreciated, as i am a novice.
     
  2. Geoelectro

    Joined:
    Feb 16, 2014
    Messages:
    324
    Likes Received:
    40
    Location:
    Houston Tx.
    I would the stick(s) calibration in the assistant software.

    Geo
     
  3. colshawn

    Joined:
    Jun 8, 2014
    Messages:
    4
    Likes Received:
    0
    i recalibrated the sticks and they show to be working fine.
     
  4. Geoelectro

    Joined:
    Feb 16, 2014
    Messages:
    324
    Likes Received:
    40
    Location:
    Houston Tx.
    So you only updated the assistant software but nothing in the Phantom?

    Geo
     
  5. colshawn

    Joined:
    Jun 8, 2014
    Messages:
    4
    Likes Received:
    0
    Geo,

    thanks for hanging with me on this, as i stated i am a beginning user.

    I connected the Phantom 2 Vision and updated the Assistant Software in the Phantom yesterday. When completed updating and rebooting the copter, I then calibrated the control sticks. I also took it outside and re-calibrated the compass.

    Then i flew it around a little and each time i would land the copter and i let it idle on the ground, the motors kept speeding up (which i have never seen it do before).

    thanks again for the advice, it is appreciated.
     
  6. Geoelectro

    Joined:
    Feb 16, 2014
    Messages:
    324
    Likes Received:
    40
    Location:
    Houston Tx.
    OK. So the assistant software and the Phantom. I know, its complicated. So with any firmware update (in the Phantom) you should run the IMU calibration. Try that if you haven't already.

    Assistant software - in computer.
    Firmware - in Phantom

    Geo
     
  7. EMCSQUAR

    Joined:
    Sep 5, 2013
    Messages:
    1,692
    Likes Received:
    6
    Location:
    N 44.895 W 93.354 Minnesota
    Take what Geo recommended and add a few steps. Whenever you do a firmware upgrade ALWAYS reload default settings from Assistant software - Tools page. Then do advanced IMU calibration, stick calibration then the compass dance. Doing all of these steps after a firmware upgrade gives you ground zero to start with.
     
  8. colshawn

    Joined:
    Jun 8, 2014
    Messages:
    4
    Likes Received:
    0
    I will try this and see if it helps.
    Thanks guys