Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 Vision + Gimbal failure

Discussion in 'Phantom 2 Vision + Discussion' started by falcon20cne, May 6, 2014.

  1. falcon20cne

    Joined:
    May 6, 2014
    Messages:
    21
    Likes Received:
    0
    Hello, new to the forum. I just purchased a vision + last week (received it 5-1) and love the thing. I have been into RC helis for years and I really love having an aerial video platform.

    So my issue is, first few flights were fine, but was really just getting the feel for the bird, so low hovering and such, gimbal and camera worked great. Sunday 5-4, started to notice that the camera was tilting in fight while hovering (on its roll axis) and would then snap back. Then flew again yesterday and the problem seemed to be happening more often so I brought it down and started trying to determine what was going on. On the bench the gimbal servos seemed very loud, I played with tilting the bird around and what appeared to be happening is that the camera would track fine then the roll access servo would let go and the camera would free hang, then the servo would kick back in and snap back into position. I was able to reproduce this issue multiple times (just to be clear the other 2 servos held fine) and then started searching the net for anyone with a similar issue, none found. I did find some forum with users having some type of gimbal issue and they suggested reloading the firmware. In the Phantom Assist software I only had 3 options for upgrades (I had also upgraded all the firmware straight out of the box, so this was really just reapplying the firmware) and did all three. The last of the 3 was the ZEN IMU, which went find but after reboot the gimbal is now completely INOP.

    below is a vid i took at the park 5-4 showing the failure at around the 3:10 area
    https://www.youtube.com/watch?v=gb_sG_MfvkM

    this is yesterday 5-5 and at aprox 1:10 it starts happening, as you can see its happening more often.
    https://www.youtube.com/watch?v=VxE8ZcZCGhg

    So it seems the gimbal is dead, I did send a request to DJI to see what i need to do and will be calling my vendor today, but wanted to share the experience and see if anyone does have any suggestions.

    Hopefully my vendor will help out and I just got a lemon.

    Thanks
     
  2. falcon20cne

    Joined:
    May 6, 2014
    Messages:
    21
    Likes Received:
    0
    Vendor is processing an exchange, hope this was just a one off issue.
     
  3. Dirty Bird

    Joined:
    Apr 15, 2014
    Messages:
    0
    Likes Received:
    9
    Location:
    Glen Burnie, MD - USA
    You could see in the second video when it begins dropping out that the motors were trembling and imparting a lot of vibration into the camera. May have been a loose connection...those little black ribbons are electrical connections and they may not have been securely seated. Or it may just be a defective camera. No sense risking it as its new so go with the replacement. The hard part is having to wait for it to arrive. :(