Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

Phantom 2 non-vision not starting up but gimble works

Discussion in 'Phantom 2 Discussion' started by sledge2216, Sep 24, 2014.

  1. sledge2216

    Joined:
    Sep 24, 2014
    Messages:
    3
    Likes Received:
    0
    I had a crash with my phantom 2 and had to replace the main board and the wireless reciever board. After replacing the parts I updated all firmware and recalibrated everything and when I power it up I get a solid green sync light and slow yellow lights from the phantom2 ( testing indoors). It will not start up at all but I have control of the gimble. I cannot find a resolution to this anywhere. Has anybody had this problem before? I have run out of Ideas on the problem and tech support is worthless. Thanks
     
  2. Buckaye

    Joined:
    Aug 24, 2014
    Messages:
    1,557
    Likes Received:
    420
    Location:
    Orlando
    Did you re-bind the controller?
     
  3. sledge2216

    Joined:
    Sep 24, 2014
    Messages:
    3
    Likes Received:
    0
  4. OI Photography

    Joined:
    Sep 23, 2013
    Messages:
    5,542
    Likes Received:
    17
    Location:
    Clarksville, TN
    Solid green light on the Phantom itself?

    After installing the firmware upgrade, did you check to see if receiver type is set to "D-bus"?
     
  5. sledge2216

    Joined:
    Sep 24, 2014
    Messages:
    3
    Likes Received:
    0
    I actually just noticed that when I try to start it up I get 5 flashing red lights and then it goes back to flashing slow yellow