Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

P3 standard help

Discussion in 'Standard/4k Discussion' started by Alistair Coppard, Jun 8, 2016.

  1. Alistair Coppard

    Joined:
    Jun 8, 2016
    Messages:
    3
    Likes Received:
    1
    Hey guys, so the other night I decided to bite the bullet and update to the latest firmware. Download went well and install seemed to also go fine but now when I start up the drone no lights come up on the arms and just emits a loud beep every second or so. Ive read threads of people having the same problem but after a crash and have tried everything they did except for just letting it do its thing for an hour or so as I dont really have a area I can do that where I wont drive myself and my flatmates crazy haha. When I do start it up the wifi wont connect (no video, drone status etc) so im at a dead end. Any ideas? possibly somehow re-installing the firmware I originally had on it? Cheers
     
  2. p.mitchell

    Joined:
    Jun 6, 2016
    Messages:
    66
    Likes Received:
    11
    i read this is due to switching it off before the update has finished. may need to redo it.

    mine did it for a while but i had it at work so just locked it in a room and let it get on with it.
     
    Alistair Coppard likes this.
  3. CClifton

    Joined:
    Apr 16, 2016
    Messages:
    18
    Likes Received:
    2
    You have to pair the controller with the drone again. Instructions can be found in the DJI Go app.


    Sent from my iPhone using PhantomPilots mobile app
     
  4. Multicoptertec

    Joined:
    Mar 4, 2016
    Messages:
    1,100
    Likes Received:
    313
    Location:
    Apollo Beach, Florida
    How did you install the update? If via device, did you get a confirmation that is was finished?
     
  5. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,649
    Likes Received:
    368
    Location:
    Pacific,NorthWet, 97031
    Check his post again, he has no lights on the bird, just beeping. I haven't heard that before.
     
  6. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,649
    Likes Received:
    368
    Location:
    Pacific,NorthWet, 97031
    No lights, how about on the gimbal?
     
  7. RodPad

    Joined:
    May 20, 2015
    Messages:
    2,649
    Likes Received:
    368
    Location:
    Pacific,NorthWet, 97031
    Find a place to let it sit and beep, a busy parking lot in a locked car at night (just so people walking by will wonder what is going on in the car).:eek:
     
  8. Alistair Coppard

    Joined:
    Jun 8, 2016
    Messages:
    3
    Likes Received:
    1
    Has a red flashing light on gimbal
     
  9. Bobcatmo

    Joined:
    Jun 9, 2016
    Messages:
    35
    Likes Received:
    25
    Location:
    Palm Coast, Florida
    The red flashing light on mine means the SD card is missing or bad.

    Does the gimbal do it's start up movement when you turn the bird on?
     
  10. Alistair Coppard

    Joined:
    Jun 8, 2016
    Messages:
    3
    Likes Received:
    1
    Got it fixed :) just let it sit and do its thing for an hour while it re-installed the latest firmware and it figured itself out :) cheers for the help guys
     
    Squirrel! likes this.
  11. Andy Roberts

    Joined:
    May 29, 2016
    Messages:
    102
    Likes Received:
    16
    Which FW have you installed? I'm on holiday in Spain at the moment so haven't been able to fly for over a week is the latest still 1.6.8? Or have they released another version?.