Welcome to PhantomPilots.com

Sign up for a weekly email of the latest drone news & information

One prop not rotating fully

Discussion in 'Phantom 2 Vision + Discussion' started by burritocmdr, Jul 11, 2014.

  1. burritocmdr

    Joined:
    Jul 11, 2014
    Messages:
    23
    Likes Received:
    0
    Hi all,

    Just got my phantom today, first time flying one. Got through the initial setup and calibration, lights show ready to fly. However, one prop is weakly rotating while the others are spinning freely. I stupidly gunned the throttle anyway and it flew upside down into the grass. Two of the props have nicks in them now.

    1. Any suggestions on how to fix the one prop not fully rotating?
    2. Will the nicks in the props affecting flight performance? Are they still usable??

    So disappointed!

    Thanks!
     
  2. chrismbrock2009

    Joined:
    Jul 4, 2014
    Messages:
    11
    Likes Received:
    0
    Sorry to hear that. I would guess you have a short to one of your motors. I would suggest DJI customer service but they are worthless. If you are knowledgable about wiring you could check the solder connections to the motor.

    Now I could be totally off base with my response but that's what comes to mind on this end.

    I'm sorry your disappointed on your first phantom. They are an amazing machine and I love mine. You just have to know going in that support from DJI is none existent
     
  3. Dcpmark

    Joined:
    May 5, 2014
    Messages:
    76
    Likes Received:
    2
    I had the same problem.....it's either a bad motor or a bad controller. Mine turned out to be a bad motor that got damaged when I used the wrong screw putting on the prop guards. Needless to say I returned the prop guards in disgust without using them, and my local dealer replaced the motor for free.
     
  4. flyNfrank

    Joined:
    Feb 1, 2014
    Messages:
    4,212
    Likes Received:
    910
    Location:
    Indy, USA
    So the motor will not make full rotations, or?

    Is there any up & down movement?

    Does it make any strange sounds compared to the other 3?
     
  5. slothead

    Joined:
    Jun 14, 2014
    Messages:
    485
    Likes Received:
    2
    Location:
    Frederick, MD, USA
    I would guess it is a faulty ESC to me, but I'm no expert.
     
  6. DCGOO

    Joined:
    Jun 4, 2014
    Messages:
    109
    Likes Received:
    0
    Location:
    Indianapolis

    Who did you buy it from? It is time to contact your dealer. Perhaps they can provide a replacement. It really sucks when your new toy does not work right out of the box. Fortunately mine worked fine, and still is.
     
  7. chrismbrock2009

    Joined:
    Jul 4, 2014
    Messages:
    11
    Likes Received:
    0
    Who did you buy the Phantom from?
     
  8. burritocmdr

    Joined:
    Jul 11, 2014
    Messages:
    23
    Likes Received:
    0
    Bought it from Amazon, Citi Drone was the seller. I have issued a replacement order thru Amazon and they have 3 days to contact me. Hopefully it will go smoothly. Man I was so excited to get it today only to be devastated when it didn't work!

    Here is a video of the problem: http://youtu.be/4OZt9UjO_YI
     
  9. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Yup, bad ESC or motor.. (assuming the Prop is in good shape)
     
  10. andrew

    Joined:
    Jun 26, 2014
    Messages:
    73
    Likes Received:
    1
    Sorry, OR faulty connection
     
  11. yali

    Joined:
    Nov 8, 2013
    Messages:
    148
    Likes Received:
    0
    Looks like you are using rubber props. Shapes changing all the time!
     
  12. Ede

    Ede

    Joined:
    Jul 14, 2014
    Messages:
    6
    Likes Received:
    0
    I have the same issue. P2V+ arrive on friday. Open the box, initial setup, firmware upgrade..etc..etc.. Went out the park,
    prop is up, prop guard is up.. start the engine... hmmm...one of the motor didn't work correctly, absolutly the same issue
    what is on the video. ? Go home, box close, product sent back. I've used the "default" prop what was included.
     
  13. burritocmdr

    Joined:
    Jul 11, 2014
    Messages:
    23
    Likes Received:
    0
    Oh man, this is beyond frustrating. I send back the defective phantom, they quickly send it back and say they repaired it. Nope. It is not repaired. It's doing exactly the same thing as before. They claim to have replaced the motor, I suppose that could be true. If so, the problem lies in the electronics. I have to question why they didn't even bother to try it out after the "repair".

    I may try for a refund if they are going to jerk me around. I've completely lost my enthusiasm :cry:
     
  14. burritocmdr

    Joined:
    Jul 11, 2014
    Messages:
    23
    Likes Received:
    0
    Did they send you a new replacement or repair it somehow?
     
  15. JWarren

    Joined:
    Jun 19, 2014
    Messages:
    773
    Likes Received:
    119
    We've had several posts over the last few days of new owners with the exact same problem. I wonder if a bad batch of motors got in the production line and they are now hitting the market.
     
  16. Soulnet

    Joined:
    Jul 12, 2014
    Messages:
    70
    Likes Received:
    1
    It's interesting cause mine has a 'sticky' motor as well. When turning the props on 3 start turning straight away while the 4th sort of spins, but a lot slower before joining the rest of them. Not saying it's the same issue (i've flew my bird about 15 times now) but wonder now if I should be careful. As a rule I sort of let the props 'warm up' for about 30 seconds before taking off (30 seconds after start up procedure).